The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Solutions for the ongoing spamd load issue

Discussion in 'General Discussion' started by sibinkc, Aug 29, 2007.

  1. sibinkc

    sibinkc Member

    Sep 9, 2006
    Likes Received:
    Trophy Points:

    We can use the following steps to resolve the load issue on a cPanel box due to the spamd processes.

    1. Edit the /etc/mail/spamassassin/ file

    vi /etc/mail/spamassassin/

    then add the following lines to it

    a) use_bayes 0 (this will disable some spamassassin functionalities)
    b) lock_method flock

    (Uncomment these options, if they are commented)

    2) run scripts2/autofixer/spamd_dbm_fix

    a) Log into WHM and use another URL as "http://your server IP:2086//scripts2/autofixer" - then type the script name "spamd_dbm_fix" and run

    b) You can also do the same from the server back end as follows.

    # chmod 755 spamd_dbm_fix
    # ./spamd_dbm_fix

    3) Run the following lines of codes

    # rm -f /home/*/.spamassassin/
    # rm -f /home/*/.spamassassin/*.lock

    NOTE : If the load issue is related to a particular user then there is no need for running this, you can simply enter into the '.spamassassin/' directory for that user and delete the files '' and *.lock.

    4) Restart spam assassin (restart Exim)

    # /scripts/restartsrv_exim

    Hope this will help you in such a situation.

    #1 sibinkc, Aug 29, 2007
    Last edited: Aug 29, 2007

Share This Page