SOLVED [SOLVED] WHM/cPanel unresponsive after reboot, SSH access

Operating System & Version
Almalinux 8
cPanel & WHM Version
11.102

mencargo

Member
Jul 30, 2013
13
1
53
Mexico
cPanel Access Level
Root Administrator
It's a new server, Almalinux 8, installed cPanel, created a couple of accounts, disabled DNS, tried to set AutoSSL that worked for one domain and didn't work for another.
Tried AutoSSL several times, removed self-signed SSL, decided to reboot.

No access to WHM, cPanel nor websites.

I'm able to access with SSH.
# systemctl status cpanel
Active: active (running)

Whitelisted my IP.

I don't see any errors in journalctl -xe, besides PAM-hulk: Brute force detection active: 550 LOGIN DENIED -- TOO MANY FAILURES
Tried running named service, nothing changes...
Tried updating to 104 changing /etc/cpupdate.conf and running /usr/local/cpanel/scripts/upcp
Still same issue [Up to date (11.103.9999.102)]
 
Last edited:

andrew.n

Well-Known Member
Jun 9, 2020
930
345
63
EU
cPanel Access Level
Root Administrator
Do you have CSF installed? Almalimux comes with firewallcmd. Can you check the output of this?

firewallcmd --state
 

mencargo

Member
Jul 30, 2013
13
1
53
Mexico
cPanel Access Level
Root Administrator
Thanks! I tried iptables and csf...

systemctl stop firewalld

Should I disable it and install CSF? Is there something wrong with the install?
Seems weird that a fresh install could have something like this, should I move to another OS?
 

kodeslogic

Well-Known Member
PartnerNOC
Apr 26, 2020
534
247
118
IN
cPanel Access Level
Root Administrator
Yes, install the CSF and check.
 

andrew.n

Well-Known Member
Jun 9, 2020
930
345
63
EU
cPanel Access Level
Root Administrator
Thanks! I tried iptables and csf...

systemctl stop firewalld

Should I disable it and install CSF? Is there something wrong with the install?
Seems weird that a fresh install could have something like this, should I move to another OS?
Did this do the trick?
 

kodeslogic

Well-Known Member
PartnerNOC
Apr 26, 2020
534
247
118
IN
cPanel Access Level
Root Administrator
Disable it so it won't autostart in the next reboot.

Code:
# systemctl disable firewalld
 

kodeslogic

Well-Known Member
PartnerNOC
Apr 26, 2020
534
247
118
IN
cPanel Access Level
Root Administrator
I am glad I was able to help.