The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Some Addon scripts not installing correctly

Discussion in 'cPanel Developers' started by blairp36, Aug 11, 2005.

  1. blairp36

    blairp36 Active Member

    Joined:
    Apr 17, 2003
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Just updated Cpanel to WHM 10.3.1 cPanel 10.5.0-C23. PHP/4.3.11, mysql (4.0.25-standard) Tested all the addon scripts to make sure they work. Everything works fine except: (Anyone else having problems with these.. Thanks for any input)

    -->Xoops:
    Warning: main(/home/blaret/public_html/xoop/class/xoopssecurity.php): failed to open stream: No such file or directory in /home/blaret/public_html/xoop/include/common.php on line 32

    Fatal error: main(): Failed opening required '/home/blaret/public_html/xoop/class/xoopssecurity.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/blaret/public_html/xoop/include/common.php on line 32

    -->PHPWiki:
    lib/WikiDB/backend/PearDB.php:32: Fatal[256]: Can't connect to database: wikidb_backend_mysql: fatal database error

    * DB Error: connect failed
    * ( [nativecode=Access denied for user: 'blaret_phpwiki1@localhost' (Using password: YES)] ** mysql://blaret_phpwiki1:XXXXXXXX@localhost/blaret_phpwiki1)

    (Note: Creates an empty database)

    -->WordPress:
    (Config file has to be created manually)

    -->AdvancedGuestBook 2.3.3:
    Warning: main(./extension.inc): failed to open stream: No such file or directory in /home/blaret/public_html/gb2/index.php on line 25

    Warning: main(./extension.inc): failed to open stream: No such file or directory in /home/blaret/public_html/gb2/index.php on line 25

    Warning: main(): Failed opening './extension.inc' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/blaret/public_html/gb2/index.php on line 25

    Warning: main(./common.): failed to open stream: No such file or directory in /home/blaret/public_html/gb2/index.php on line 26

    Warning: main(./common.): failed to open stream: No such file or directory in /home/blaret/public_html/gb2/index.php on line 26

    Warning: main(): Failed opening './common.' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/blaret/public_html/gb2/index.php on line 26

    Fatal error: Call to undefined function: session_pagestart() in /home/blaret/public_html/gb2/index.php on line 31
     
    #1 blairp36, Aug 11, 2005
    Last edited: Aug 11, 2005
  2. eos1

    eos1 Well-Known Member

    Joined:
    Mar 11, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    16
  3. cPanelBilly

    cPanelBilly Guest

    There was a bug in 2.0.13 This has been fixed with the upgrade done to 2.0.13.1

    I have replicated issues with this, it is an old version and will be updated soon

    I replicated the issue and have fixed it.

    I cannot replicate this. I just did 5 installs using latest edge and AGB installer and all went fine.
     
  4. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    I just tested AGB and it worked fine, so if you could open a ticket on that one so I can look at your specific server. You may want to try to uninstall/reinstall.

    Xoops is now fixed, just a file missing.

    But if you could open a ticket on the AGB and WP issue, I'd appreciate being able to look at your server directly (Attention Nick Nelson)
     
  5. raxafarian

    raxafarian Member

    Joined:
    Aug 29, 2003
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    2 addon problems when I upgraded from 10.2.x to 10.6.0-R55

    AGB installs fine, but does not seem to create the admin user. Unable to log in as admin.

    Counter (cgi) no longer working. Just a broken image where the counter should be.
     
  6. eos1

    eos1 Well-Known Member

    Joined:
    Mar 11, 2003
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    16
    Thank you, Nick, Nickn and Billy.
    I know it's hard to update those scripts each...but that's end users want as you know.
    and this is one of CPANEL's best things.
     
  7. carock

    carock Well-Known Member

    Joined:
    Sep 25, 2002
    Messages:
    232
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    St. Charles, MO
    Sync addon scripts separately

    Is there a way to sync or update the addon scripts separately from the whole Cpanel software.

    I broke a production server upgrading to the latest release (WHM 10.6.0 cPanel 10.6.0-R55) and I'm not going to upgrade to an edge to fix the Xoops addon script.

    Unfortunately, I don't have an unused server to "borrow" the latest addon package that appears to fix the problem, so I was hoping someone had a /script utility or something to get the latest fixed addon script package for Xoops.

    Anyone?

    How about adding a Cpanel function in WHM to get addon script updates without upgrading all of Cpanel?

    Thanks,
    Chuck
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Yup:

    /usr/local/cpanel/whostmgr/bin/whostmgr2 --updateaddons
     
Loading...

Share This Page