Some clients complain of issues receiving emails

TCB13

Well-Known Member
Jul 25, 2014
62
1
8
cPanel Access Level
Root Administrator
Hello,

I've regularly some clients complaining that they can receive emails from some addresses. The sender also gets messages similar to this one:

Code:
[email protected]<mailto:[email protected]>
server.mynetwork.com<http://server.mynetwork.com> #550-Verification failed for <[email protected]<mailto:[email protected]>> 550-Called: x.x.x.x 550-Sent: RCPT TO:<[email protected]<mailto:[email protected]>> 550-Response: 550 Empty envelope senders not allowed 550 Sender verify failed ##

Cabeçalhos da mensagem originais:

Received: from srv-exch-01.remoteserver.pt<http://srv-exch-01.remoteserver.pt> ([172.16.1.41]) by
srv-exch-01.remoteserver.pt<http://srv-exch-01.remoteserver.pt> ([172.16.1.41]) with mapi; Tue, 13 Jan 2015
10:37:46 +0000
From: Guy Name <[email protected]<mailto:[email protected]>>
To: Another Person <[email protected]<mailto:[email protected]>>, "MyClient"
       <[email protected]<mailto:[email protected]>>
Date: Tue, 13 Jan 2015 10:37:45 +0000
Subject: =?iso-8859-1?Q?Qual_ser=E1_a_m=E1quina_ideal_para_o_LAL_OFF_Road=3F?=
Thread-Topic: =?iso-8859-1?Q?Qual_ser=E1_a_m=E1quina_ideal_para_o_LAL_OFF_Road=3F?=
Thread-Index: AdAvHPeJeQQwOZsTRmel4YvLbg6aCQ==
Message-ID: <[email protected]ver.pt<mailto:[email protected]ver.pt>>
Accept-Language: pt-PT
Content-Language: pt-PT
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator:
acceptlanguage: pt-PT
x-tm-as-product-ver: SMEX-11.0.0.1191-7.500.1018-21246.003
x-tm-as-result: No--35.402200-8.000000-31
x-tm-as-user-approved-sender: No
x-tm-as-user-blocked-sender: No
Content-Type: multipart/related;
       boundary="_004_06463CE10759E34AAC59434B4A53A6B71C2D1DB668srvexch01mota_";
       type="multipart/alternative"
MIME-Version: 1.0
I don't see on this error message where is the "Empty envelope sender", it has an email. How can I track and fix this?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,219
463
Hello :)

This typically happens when the remote sender does not utilize the "Envelope From" address when sending their email to your server. Thus, since "Sender Verification" is enabled in your Exim Configuration Manager, it bounces the message back to the sender. Are you able to reproduce this issue and review the message headers of the person sending the message?

Thank you.
 

TCB13

Well-Known Member
Jul 25, 2014
62
1
8
cPanel Access Level
Root Administrator
Hello :)

This typically happens when the remote sender does not utilize the "Envelope From" address when sending their email to your server. Thus, since "Sender Verification" is enabled in your Exim Configuration Manager, it bounces the message back to the sender. Are you able to reproduce this issue and review the message headers of the person sending the message?

Thank you.
Unfornatuly I can't reproduce this on a controlled remote environment.

However, this issue made me thing about how WHM/cPanel handle incoming email with errors and look in how other providers do it.

From my research I found that email providers such as Gmail, have a much more viable approach to poorly formatted emails, instead of just refusing them at first sight, they, accept it (in most cases) and mark it as SPAM.

For instance, if I've DKIM enabled for an account, the account will just refuse email that isn't properly signed, Gmail instead accepts the incoming email but marks it as SPAM. => This is what cPanel should also be doing...

Let's be realistic, most email servers are poorly configured and/or don't rely on a good configuration like the ones powered by WHM and the final client who buys hosting doesn't care about the tech reasons behind the failures, just complains. cPanel should take the same approach as Gmail for treating poorly formatted and invalid email, this way clients will always be happy and us too.

I made a feature request on this here: cPanel Feature Requests: DKIM & Sender Verification Fails to Spam Instead of Refusing Them
(It's currently pending moderation).

Thank you.
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,219
463
Thank you for taking the time to submit a feature request. Note that you can disable "Sender Verification" under the "Mail" tab in "WHM Home » Service Configuration » Exim Configuration Manager" and allow SpamAssassin or your own custom filters mark the messages as SPAM.

Thank you.