The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

some domains on 3rd DNS server in a cluster do not respond

Discussion in 'Bind / DNS / Nameserver Issues' started by hicom, Jun 27, 2011.

  1. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    272
    Likes Received:
    0
    Trophy Points:
    16
    We have 3 DNS servers using cPanel Cluster. Two are shared servers and one is a dedicated DNS.

    The 3rd DNS server which was added at a later time is showing a strange problem. Some domains that were setup on DNS1 or DNS2 are not being answered for on DNS3.

    The strange thing, only some domains have this issue of not resolving. Their .db file exist on the server BUT there is no reference to that .db file in named.conf

    DNS1 and DNS2 are FreeBSD 6
    DNS3 that is having this issue of not answering SOME zones is CentOS 5

    How to go about syncing these domains properly?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You mentioned that the zones do exist on the server, but they are not found within the /etc/named.conf file.

    Please try running the following command on the server to see if it results in the zones being included within the /etc/named.conf file:

    Code:
    # /scripts/rebuilddnsconfig
    Thank you.
     
  3. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    272
    Likes Received:
    0
    Trophy Points:
    16
    Wonderful! Thank you much Michael. Running /scripts/rebuilddnsconfig and then restarting BIND fixed it.
     
Loading...

Share This Page