Some icons missing after upgrade to 11.52

snewton

Active Member
Aug 4, 2015
26
6
53
Redford, MI
cPanel Access Level
Root Administrator
After upgrading to 11.52, I found that the following icons are missing in Paper Lantern:

All CloudFlare icons

In Software:

Softaculous Auto Installer
Select PHP Version

I've tried running:

/scripts/upcp --force
/usr/local/cpanel/bin/rebuild_sprites

I've also tried reinstalling CloudFlare and Softaculous as well.

No luck :(

Anyone else having this issue?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
I've also tried reinstalling CloudFlare and Softaculous as well.
Hello :)

What method did you use to reinstall those applications? For instance, CloudFlare offers installation instructions at:

cloudflare/CloudFlare-CPanel · GitHub

You may want to try uninstalling and installing the applications to see if that makes a difference, or consult with the providers of these applications.

Thank you.
 

MediaServe

Well-Known Member
PartnerNOC
Apr 9, 2004
138
2
168
Nashville, TN USA
cPanel Access Level
DataCenter Provider
Twitter
What exactly is this issue here? I have several third party add ons with missing icons in paper lantern now. The third party plugins that have no icons are:

cPremote Backup Management
Auto install SSL (from thesslstore.com)
Select PHP Version (from CloudLinux)
Site Builder (from Site.pro)
Softaculous Apps Installer

Is there something the vendors of these plugins are required to change to be compatible with the late paper lantern?
 

wintech2003

Well-Known Member
PartnerNOC
Sep 15, 2010
69
19
58
Greece
cPanel Access Level
DataCenter Provider
Same here. Pretty much whatever custom Plugin I have installed, is missing it's icons after upgrading to v11.52
  • CloudFlare
  • Softaculous
  • CloudLinux's "Select PHP Version"
  • SpamExperts
  • Remote MX Wizard
I've tried to reinstall the CloudFlare plugin and found the following errors:
Code:
info [install_plugin] Installing to paper_lantern
warn [install_plugin] An error occoured will loading the theme DynamicUI: The configuration entry with “id” of “lverubysel” lacks the required parameter “name”.
info [install_plugin] Running sprite_generator
warn [install_plugin] sprite_generator returned a non-zero exit code, your icon may or may not appear.
and

Code:
The configuration entry with “id” of “lverubysel” lacks the required parameter “name”.
at /usr/local/cpanel/Cpanel/Exception.pm line 151.
Cpanel::Exception::new("Cpanel::Exception::MissingParameter", "The configuration entry with \x{e2}\x{80}\x{9c}[_1]\x{e2}\x{80}\x{9d} of \x{e2}\x{80}\x{9c}[_2]\x{e2}\x{80}\x{9d} lacks t"..., ARRAY(0x17de098)) called at /usr/local/cpanel/Cpanel/Exception.pm line 57
Cpanel::Exception::create("MissingParameter", "The configuration entry with \x{e2}\x{80}\x{9c}[_1]\x{e2}\x{80}\x{9d} of \x{e2}\x{80}\x{9c}[_2]\x{e2}\x{80}\x{9d} lacks t"..., ARRAY(0x17de098)) called at /usr/local/cpanel/Cpanel/Themes/Assets/Base.pm line 44
Cpanel::Themes::Assets::Base::new("Cpanel::Themes::Assets::Link", "icon", "/usr/local/cpanel/base/frontend/paper_lantern/styled/basic/ic"..., "id", "lverubysel") called at /usr/local/cpanel/Cpanel/Themes/Serializer/DynamicUI.pm line 194
Cpanel::Themes::Serializer::DynamicUI::_dui2link(Cpanel::Themes::Serializer::DynamicUI=HASH(0x15d9460), HASH(0x179f610)) called at /usr/local/cpanel/Cpanel/Themes/Serializer/DynamicUI.pm line 62
Cpanel::Themes::Serializer::DynamicUI::build_data_tables(Cpanel::Themes::Serializer::DynamicUI=HASH(0x15d9460)) called at /usr/local/cpanel/Cpanel/Themes/Serializer/Base.pm line 88
Cpanel::Themes::Serializer::Base::links(Cpanel::Themes::Serializer::DynamicUI=HASH(0x15d9460)) called at /usr/local/cpanel/bin/sprite_generator line 170
Cpanel::Bin::SpriteGenerator::_run_new_sprite_generator(HASH(0x9cd380)) called at /usr/local/cpanel/bin/sprite_generator line 118
Cpanel::Bin::SpriteGenerator::run(1444873713) called at /usr/local/cpanel/bin/sprite_generator line 9
Above icons work fine on servers that haven't been upgraded to v11.52 yet.

Regards,
- G.
 

CBG

Active Member
Apr 23, 2010
39
2
58
cPanel Access Level
Root Administrator
Hi,

We are missing the below icons and running cPanel 11.52.0 (Build 17)
R1Soft, Installatron and Select PHP Version (CloudLinux)
 

elialum

Active Member
Sep 10, 2008
29
1
53
Israel
cPanel Access Level
DataCenter Provider
This was already reported by us to cPanel (CASE-800), 4 months ago when version 11.52 was still on EDGE.
We are keep getting responses that they can't find / replicate the problem (we are still getting same response...)

:(
 

elialum

Active Member
Sep 10, 2008
29
1
53
Israel
cPanel Access Level
DataCenter Provider
True, we reported this for our "BackupManager" plugin. But Icons from these plugins as well are not working -

(as reported by @wintech2003)
  • CloudFlare
  • Softaculous
  • CloudLinux's "Select PHP Version"
  • SpamExperts
  • Remote MX Wizardd
..these are also custom plugins, AFAIK.

So as it looks, all custom plugins cannot generate icons (SPRITE) on registration, perhaps (not verified yet) only on CloudLinux systems.

Eli.
 

Infopro

Well-Known Member
May 20, 2003
17,113
507
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
From the recent Softaculous updates notes:
5) [Bug Fix] : Due to a recent upgrade in cPanel's paper_lantern theme, Softaculous was not working properly in Native UI. This has been fixed now.
I can confirm that in 11.52.0 (build 17) I have Softaculous and CloudFlare icons working as expected as of this morning. That's not to say that CASE-2007 is resolved, it's not.
 

elialum

Active Member
Sep 10, 2008
29
1
53
Israel
cPanel Access Level
DataCenter Provider
cPanel 11.52.0 (build 17) with CloudLinux

- No Icons for softaculous (v4.6.7)
- No icons for cloudflare
- No icons for Jetserver BackupManager

All are working well on a non-cloudlinux server (just verified).
 

Attachments

hostdog.gr

Registered
Oct 10, 2013
1
0
1
cPanel Access Level
Root Administrator
Our workaround for this
( The configuration entry with “id” of “lverubysel” lacks the required parameter “name”. ) error during /usr/local/cpanel/bin/sprite_generator

Was to disable via WHM LVE management the following options:
Hide Ruby App in web-interface
Hide Python App in web-interface

Then run again: /usr/local/cpanel/bin/sprite_generator which produced no errors, then you can re-hide Ruby/Python App if you wish.
 

amin alnasra

Member
Apr 16, 2015
9
0
1
palestine
cPanel Access Level
Root Administrator
Our workaround for this
( The configuration entry with “id” of “lverubysel” lacks the required parameter “name”. ) error during /usr/local/cpanel/bin/sprite_generator

Was to disable via WHM LVE management the following options:
Hide Ruby App in web-interface
Hide Python App in web-interface

Then run again: /usr/local/cpanel/bin/sprite_generator which produced no errors, then you can re-hide Ruby/Python App if you wish.
Thank you it works for me <3
 

ChadTaylor

Registered
Nov 3, 2015
1
0
1
cPanel Access Level
Website Owner
Pretty much I am facing same issue as well, Tried some methods but still no Luck :( Is their any option we can take help from Live support? If yes Please share.

Regards
- Removed -
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Hello :)

A resolution is included with cPanel version 11.52.0.21:

Fixed case CPANEL-2007: Handle "skipobj" lines in the dynamicui files.

Feel free to let us know if the issue persists after updating cPanel.

Thank you.
 

4u123

Well-Known Member
PartnerNOC
Jan 2, 2006
931
21
168
Exactly the same problem on version 54 now. All those same icons missing from paper lantern.