Some icons missing after upgrade to 11.52

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,225
463
Exactly the same problem on version 54 now. All those same icons missing from paper lantern.
Could you verify if you are using Cloud Linux? They recently released a bug fix:

Beta: LVEManager updated

LVEMAN-543 - fix DynamicUI configuration bug with LVE Manager


Thank you.
 

newjustice

Registered
Aug 18, 2011
2
0
51
How about r1soft icon?
I run WHM 54.0 (build 15) and r1soft icon is missing, how can we add this option in the new theme ?
 

wired420

Active Member
Nov 17, 2005
35
2
158
This is getting really annoying that this is re-broken in every new release. How about you all grab an idea and stick with it, instead of changing the same code over and over. Or you know. Keep it off the RELEASE and STABLE versions until it works. We purposefully use stable and get nothing but bugs lately, then come here and watch you pass off the blame as if it's some other companies fault when you made no one aware the change was coming.

cPanel used to do business better than this and is why I've stuck around instead of moving to free or cheaper products. If you keep breaking STABLE releases I'm going to move along after 10+ years of loyalty.
 

wired420

Active Member
Nov 17, 2005
35
2
158
BTW. The cloudlinux icons can be fixed by simply copying the files to the right location and rebuilding sprites.

Code:
cp /usr/local/cpanel/base/frontend/x3/branding/enduserlve.png /usr/local/cpanel/base/frontend/{yourtheme}/styled/basic/icons/
/usr/local/cpanel/bin/sprite_generator --theme {yourtheme}
Replace {yourtheme} with the name of the theme you want to fix. For example if you wanted to fix the paper lantern theme (We use a custom one), you'd replace "{yourtheme}" with "paper_lantern". I'd assume you could do the same with other plugins if you find the correct file to copy. All the other plugins we have issues with are our own. It's getting really annoying having to fix by hand or remember to run a post install script to fix this on every new server.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,225
463
Hello :)

The changes to requirements for Paper Lantern plugins are documented in the cPanel 54 release notes:

54 Release Notes - Documentation - cPanel Documentation

In particular, this change is one that requires developers to update their plugins:

jQuery requirements for custom interfaces
In cPanel & WHM version 54, we reduced the cPanel interface's jQuery needs to use only one version of jQuery, and modified the way in which the cPanel interface loads jQuery. Due to these changes, third-party developers must update their custom interface code to handle jQuery properly. For more information, read our Guide to cPanel Interface Customization - jQuery documentation.
We publish development releases that users can test their plugins on before those versions make their way to additional build tiers:

cPanel & WHM Product Versions and the Release Process - cPanel Knowledge Base - cPanel Documentation

Another useful tool for plugin develops is the Edge-Users mailing list, where discussions of changes in new/development versions of cPanel are discussed:

Edge-Users Info Page

Thank you.