Some incoming emails lost: trying to understand exim logs

bluecup

Member
May 30, 2014
16
2
53
cPanel Access Level
Website Owner
I am having some issues where some emails from a website are delivered and some go missing. I was looking at the exim logs and trying to understand the lines. I have added my comments below each line. Feel free to correct me if my understanding is wrong.

2014-05-29 09:22:03 1Tpg3O-0004Nz-0t <= [email protected] U=nast P=local S=2901 T="Contact Form" for [email protected]
  • Basically in the website form, the form is configured to be sent to the admin email of a website ([email protected]) which is being hosted by a company domain1.com. I don't know what this address is: [email protected]. "nast" is the username of domain2.com. Some emails are received in [email protected] while some get lost. I'm trying to find out what's happening.


2014-05-29 09:22:03 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1Tpg3O-0004Nz-0t
  • I guess this is just a mail spool if I am correct. Probably nothing wrong here.


2014-05-29 09:22:03 1Tpg3O-0004Nz-0t SMTP connection outbound 1401288126 1Tpg3O-0004Nz-0t domain2.com [email protected]
  • Why is domain2.com added in this line?

2014-05-29 09:22:04 1Tpg3O-0004Nz-0t => [email protected] R=lookuphost T=remote_smtp H=mx3.hotmail.com [207.46.8.167] C="250 <[email protected]@servername.domain1.com> Queued mail for delivery"
2014-05-29 09:22:04 1Tpg3O-0004Nz-0t Completed
  • This looks like an outbound email where it is sending a confirmation notification to the sender: [email protected]. This seems fine to me.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello :)

You mentioned that some emails go missing. Are the missing emails the ones you see in /var/log/exim_mainlog? Is it possible the messages were sent out and have simply been added to the SPAM folder in Hotmail?

Thank you.
 

bluecup

Member
May 30, 2014
16
2
53
cPanel Access Level
Website Owner
You mentioned that some emails go missing. Are the missing emails the ones you see in /var/log/exim_mainlog? Is it possible the messages were sent out and have simply been added to the SPAM folder in Hotmail?
Thanks for your reply. There has been a typo in my message. [email protected] should read as [email protected]. I couldn't edit the original post.

The emails that go missing are the incoming emails that are supposed to be received in [email protected]. Hotmail email is the sender's email. Sender is receiving emails fine.

I am finding is hard to understand the first line of the exim logs. Please see my comments for the first line of the log.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Search for the email address that sent you the message with commands such as:

Code:
exigrep [email protected] /var/log/exim_mainlog
exigrep [email protected] /var/log/exim_rejectlog
This will help organize the log output and should let you know why your server rejected the message if that indeed happened.

Thank you.