Some questions in ONE single thread - Can't find correct answers

Operating System & Version
CENTOS
cPanel & WHM Version
v100.0.7

mo80

Member
Jan 26, 2022
8
1
3
US
cPanel Access Level
Root Administrator
Hi to everyone, I am running many servers for customers and also for my own hosting company - Problem I face on the options when I have different demands from different customers like Some wants LITESPEED + CLOUDLINUX and Some wants CLOUDLINUX only.

So below I am asking a questions with SCENARIO of cPanel server with CLOUDLINUX v7.9.0 and LITESPEED 6.0.11 (build 5) installed on this.

1) What PHP Handler should I use with LITESPEED + CLOUDLINUX based cPanel Server v100.0.7?

A) LSAPI
B) CGI
C) SUPHP
D) NONE

2) What EasyApach 4 profile should I use with LITESPEED + CLOUDLINUX based cPanel Server v100.0.7?

A) CloudLinux + All PHP Options + OpCache
B) CloudLinux + All PHP Options + OpCache + mod_lsapi
C) CloudLinux + All PHP Options + ZendGuard
D) CloudLinux + All PHP Options + ZendGuard + mod_lsapi

3) What PHP should I Use with LITESPEED + CLOUDLINUX based cPanel Server v100.0.7?

A) ea-php
B) alt-php

4) What selector should I use with LITESPEED + CLOUDLINUX based cPanel Server v100.0.7?

A) PHP Selector from cloudlinux
B) MultiPHP Manager from cPanel

Note: Answer with understanding that I have LITESPEED + CLOUDLINUX based cPanel Server v100.0.7
 

vacancy

Well-Known Member
Sep 20, 2012
523
203
93
Turkey
cPanel Access Level
Root Administrator
1) It doesn't matter. Apache handlers are irrelevant if you are using litespeed because litespeed uses the integrated lsapi handler.

2) CloudLinux + All PHP Options + OpCache profile is suitable, you can select and activate optional modules separately, it depends on the websites running on your server.

3) It doesn't matter. alt-php represents cloudlinux selector versions, the advantage of alt-php is that customers can turn any php modules they want on or off. ea-php is cpanel's php version selector. You can actively use both, customers can choose what they want.

4) I gave the answer in the question above, both can be used.