The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sophie Error [Solved - kinda]

Discussion in 'E-mail Discussions' started by leighj, Sep 25, 2007.

  1. leighj

    leighj Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    I was reviewing exim_mainlog and found the following errors
    Code:
    malware acl condition: unable to connect to sophie UNIX socket (/var/run/sophie).
    Which is VERY strange as I don't use it but rather clam av. I restarted exim and nothing... I noticed that it started yesterday about the time that daily upcp runs.

    So I went and looked at the exim configuration (from WHM)nothing seemed amiss
    Code:
    !!# These options specify the Access Control Lists (ACLs) that
    #!!# are used for incoming SMTP messages - after the RCPT and DATA
    #!!# commands, respectively.
    
    av_scanner = clamd:/var/clamd
    I then resaved and then saw
    Code:
    malware acl condition: clamd: unable to connect to UNIX socket /var/clamd (No such file or directory)
    CLOSER
    Finally I restarted exim manually.
    Code:
    /etc/init.d/exim restart
    And things seems to work fine

    Did something change in the past couple days that would affect exim? I'm running WHM 11.2.0 cPanel 11.11.0-S16999
     
  2. nxds

    nxds Well-Known Member

    Joined:
    Jan 6, 2006
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    I got this sophie error too on 2 servers since 4.50am last night. A manual restart didn't fix it, but I restored default exim config and it worked again. I put back my custom acls and it's been fine since. I also got the clamd: unable to connect to UNIX socket /var/clamd but I think that was because the service exim start had yet to start clamd.
     
Loading...

Share This Page