The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SourceGuardian Error Message in Fantastico..

Discussion in 'General Discussion' started by billau, Jul 17, 2004.

  1. billau

    billau Well-Known Member

    Joined:
    Dec 24, 2003
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brisbane, Australia
    I am getting the following error when I try to access Fantastico from my cpanel:

    PHP script /usr/local/cpanel/base/frontend/x/fantastico/includes/enc_restrictions.inc.php is protected by SourceGuardian and requires file ixed.lin.4.2.3.pxp.
    Please read SourceGuardian protected scripts manual.

    Do the following....

    Log into your server and su
    Code:
    mkdir /usr/local/ixed
    cp /tmp/ixed/ixed.lin.4.2.3.pxp /usr/local/ixed/
    pico /usr/local/cpanel/3rdparty/etc/php.ini


    Find
    Code:
    "extension_dir = ./

    and change to
    Code:
    extension_dir =

    Further down (after the line ";zend_extension="/usr/local/Zend/lib/ZendOptimizer.so") add:
    Code:
    extension="/usr/local/ixed/ixed.lin.4.2.3.pxp"


    Save and exit.
    Now protect this file:
    Code:
    chattr +i /usr/local/cpanel/3rdparty/etc/php.ini

    Thats it..

    If it is a FreeBSD server the line

    extension="/usr/local/ixed/ixed.lin.4.2.3.pxp"
    must be changed to:
    extension="/usr/local/ixed/ixed.fre.4.2.3.pxp"
     
  2. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
  3. ricardom

    ricardom Active Member

    Joined:
    Mar 10, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    This fix the error for me

    First try this:

    Code:
    chmod -R 0755 /usr/local/cpanel/3rdparty/etc/ixed
    
    If you get an error, or if that doesn't fix the problem, read on:

    EASY (places ixed decoder files at /tmp)

    LINUX:

    Code:
    cd /tmp 
     chattr -i ixed 
     rm -Rf ixed* 
     wget -N http://netenberg.com/files/ixed.tgz 
     tar xzpf ixed.tgz 
     rm -f ixed.tgz 
     chown -R root.root /tmp/ixed 
     chmod -R 0755 /tmp/ixed 
     chattr +i ixed
     
    FreeBSD:

    Code:
    cd /tmp 
     chflags noschg ixed 
     rm -Rf ixed* 
     wget -N http://netenberg.com/files/ixed.tgz 
     tar xzpf ixed.tgz 
     rm -f ixed.tgz 
     chown -R root.root /tmp/ixed 
     chmod -R 0755 /tmp/ixed 
     chflags schg ixed
    
    Source: http://netenberg.com/forum/viewtopic.php?t=1937
     
  4. Aric1

    Aric1 Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    Hello,

    The main problem most people are having is that CPANEL was chmodding the ixed files so Fantastico couldn't read them. This is fixed in 9.9.2E5.

    If you don't want to go edge, just execute:

    chmod -R 0755 /usr/local/cpanel/3rdparty/etc/ixed
     
  5. cPanelBilly

    cPanelBilly Guest

    Close, but it was the otherway around. Fantastico was chattr +i files so that PHP/cPanel could not read and update them. The easiest current fix is to:
    LINUX
    chattr -i /usr/local/cpanel/3rdparty/etc/php.ini
    /usr/local/cpanel/bin/checkphpini

    FREEBSD
    chflags noschg /usr/local/cpanel/3rdparty/etc/php.ini
    /usr/local/cpanel/bin/checkphpini

    Please note that chattr +i (freebsd: chflags noschg)any files renders your cPanel installation supportless from cPanel. So we do not recommend chattr +i any files.
     
  6. Aric1

    Aric1 Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    Actually, that's a separate issue, that can also cause the issue and actually, Fantastico was chattr +i'ing the php.ini file originally because cpanel was removing the ixed line.

    Assuming you (the server admin) have the latest ixed files in /usr/local/cpanel/3rdparty/etc/ixed/ (which Fantastico installs) and the correct line is in the /usr/local/cpanel/3rdparty/etc/php.ini file to begin with (which the Fantastico installer adds and cpanel now correctly maintains thanks to checkphpini), there should never be a problem with SG unless the sysadmin upgrades to a new version of PHP for which there isn't an ixed file yet.

    The only problem left was the ixed files being chmodded to this:

    ./ixed:
    total 1612
    drwxr-xr-x 2 root root 4096 Oct 8 18:00 ./
    drwxr-xr-x 3 root root 4096 Oct 11 20:54 ../
    -rw------- 1 root 502 40748 Feb 25 2004 ixed.fre.4.1.0.pxp
    -rw------- 1 root 502 40748 Feb 25 2004 ixed.fre.4.1.1.pxp
    -rw------- 1 root 502 40748 Feb 25 2004 ixed.fre.4.1.2.pxp
    -rw------- 1 root 502 40748 Feb 25 2004 ixed.fre.4.2.0.pxp
    -rw------- 1 root 502 40558 Feb 25 2004 ixed.fre.4.2.1.pxp
    -rw------- 1 root 502 40558 Feb 25 2004 ixed.fre.4.2.2.pxp
    -rw------- 1 root 502 40558 Feb 25 2004 ixed.fre.4.2.3.pxp
    -rw------- 1 root 502 40558 Feb 25 2004 ixed.fre.4.3.0.pxp
    -rw------- 1 root 502 40558 Feb 25 2004 ixed.fre.4.3.1.pxp
    -rw------- 1 root 502 40558 Feb 25 2004 ixed.fre.4.3.2.pxp
    -rw------- 1 root 502 40558 Feb 25 2004 ixed.fre.4.3.3.pxp
    -rw------- 1 root 502 40558 Feb 25 2004 ixed.fre.4.3.4.pxp
    -rw------- 1 root 502 40558 Feb 25 2004 ixed.fre.4.3.5.pxp
    -rw------- 1 root root 40558 Oct 8 18:00 ixed.fre.4.3.6.pxp
    -rw------- 1 root root 40558 Oct 8 18:00 ixed.fre.4.3.7.pxp
    -rw------- 1 root root 40558 Oct 8 18:00 ixed.fre.4.3.8.pxp
    -rw------- 1 root root 40558 Oct 8 18:00 ixed.fre.4.3.9.pxp
    -rw------- 1 root 502 42216 Feb 25 2004 ixed.lin.4.0.6.pxp
    -rw------- 1 root 502 42148 Feb 25 2004 ixed.lin.4.1.0.pxp
    -rw------- 1 root 502 42148 Feb 25 2004 ixed.lin.4.1.1.pxp
    -rw------- 1 root 502 42148 Feb 25 2004 ixed.lin.4.1.2.pxp
    -rw------- 1 root 502 42148 Feb 25 2004 ixed.lin.4.2.0.pxp
    -rw------- 1 root 502 41958 Feb 25 2004 ixed.lin.4.2.1.pxp
    -rw------- 1 root 502 41958 Feb 25 2004 ixed.lin.4.2.2.pxp
    -rw------- 1 root 502 41958 Feb 25 2004 ixed.lin.4.2.3.pxp
    -rw------- 1 root 502 42479 Feb 25 2004 ixed.lin.4.2.ts.pxp
    -rw------- 1 root root 45262 Oct 8 18:00 ixed.lin.4.3.0.pxp
    -rw------- 1 root root 45262 Oct 8 18:00 ixed.lin.4.3.1.pxp
    -rw------- 1 root root 45262 Oct 8 18:00 ixed.lin.4.3.2.pxp
    -rw------- 1 root root 45262 Oct 8 18:00 ixed.lin.4.3.3.pxp
    -rw------- 1 root root 45262 Oct 8 18:00 ixed.lin.4.3.4.pxp
    -rw------- 1 root root 45262 Oct 8 18:00 ixed.lin.4.3.5.pxp
    -rw------- 1 root root 45262 Oct 8 18:00 ixed.lin.4.3.6.pxp
    -rw------- 1 root root 45262 Oct 8 18:00 ixed.lin.4.3.7.pxp
    -rw------- 1 root root 45262 Oct 8 18:00 ixed.lin.4.3.8.pxp
    -rw------- 1 root root 45262 Oct 8 18:00 ixed.lin.4.3.9.pxp
    -rw------- 1 root 502 42479 Feb 25 2004 ixed.lin.4.3.ts.pxp
    -rw-r--r-- 1 root 502 65 Feb 23 2004 README

    so Fantastico couldn't read the files.

    The problem is solved now, thankfully.
     
  7. SageBrian

    SageBrian Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    415
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    NY/CT (US)
    cPanel Access Level:
    Root Administrator

    This worked for me. However, note that it is not 'fixed' in cPanel 9.9.6-E8. I just upgraded this morning and had the error.
    Running the above commands fixed it though.

    Brian
     
  8. Aric1

    Aric1 Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    You also upgraded Apache, too, didn't you?

    If so, that's what caused the issue (installing a new version of PHP will do that since the ixed file listed in the 3rdparty php.ini file is no longer correct). checkphpini verifies the version of PHP you have installed and makes sure the line in php.ini matches it.
     
  9. botakedan

    botakedan Member

    Joined:
    Sep 23, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    this code just enough... and its works

    and last but not least:
    Code:
    - chmod -R 0755 /usr/local/cpanel/3rdparty/etc/ixed
     
  10. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    This fixes it:
    /usr/local/cpanel/bin/checkphpini

    However, I have to run this every single time I run upcp. This little script does not harm anything, so how about adding this to upcp? Please?

    FYI, I added it to postupcp, but apparently that script gets run before cpanel php is rebuilt...
     
  11. fusioncroc

    fusioncroc Well-Known Member

    Joined:
    Sep 28, 2004
    Messages:
    261
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    U.K.
    this normaly happens to me to every 1 or 2 upgrades of cpanel
     
  12. Aric1

    Aric1 Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    This is because cpanel fixed these issues and then those fixed dropped out at some point a few builds after they were fixed.

    Of course, if you go to the Netenberg.com forum, the FAQ has you covered...

    http://netenberg.com/forum/viewtopic.php?t=2082

    You can put almost anything you want in that file and it will be executed after upcp runs.
     
  13. fusioncroc

    fusioncroc Well-Known Member

    Joined:
    Sep 28, 2004
    Messages:
    261
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    U.K.
    it used to fix but now im using php 4.3.10 the ixed files are useless :(
     
  14. fusioncroc

    fusioncroc Well-Known Member

    Joined:
    Sep 28, 2004
    Messages:
    261
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    U.K.
    where do i download the ixed.lin.4.3.10.pxp
     
  15. fusioncroc

    fusioncroc Well-Known Member

    Joined:
    Sep 28, 2004
    Messages:
    261
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    U.K.
    also i cant cp the 4.3.9 to 4.3.10 because of securetmp
     
  16. fusioncroc

    fusioncroc Well-Known Member

    Joined:
    Sep 28, 2004
    Messages:
    261
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    U.K.
    fixed now just cp'ed the ixed file in /3rdparty
     
  17. sumith

    sumith Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    96
    Likes Received:
    2
    Trophy Points:
    8
  18. Raheel

    Raheel Registered

    Joined:
    Aug 25, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Source gaurdian

    Hi,

    If you run CPanel 9.9.9 (build 37) or newer, just activate
    SOURCEGUARDIAN in WHM -> Tweak Settings ("Software" Box).

    Raheel Najmi.
    Nanosoft Technologies
    www.nanosofttek.com
     
Loading...

Share This Page