The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spam Assassin spamd max children setting?

Discussion in 'General Discussion' started by sneader, Aug 16, 2007.

  1. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    10-30 times per hour, my /var/log/maillog is showing:


    (snip)
    Aug 16 17:38:21 www4 spamd[30280]: prefork: server reached --max-children setting, consider raising it
    Aug 16 17:38:31 www4 spamd[30280]: prefork: server reached --max-children setting, consider raising it
    Aug 16 17:49:42 www4 spamd[30280]: prefork: server reached --max-children setting, consider raising it
    Aug 16 17:51:08 www4 spamd[30280]: prefork: server reached --max-children setting, consider raising it
    (snip)

    Not finding much in the forms on this -- any push in the right direction would be appreciated.

    - Scott
     
  2. mpkapadia

    mpkapadia Active Member

    Joined:
    Apr 10, 2002
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Any luck with this . I am trying to find out the same thing
     
  3. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    No, I've not had any luck in figuring this problem out yet. Any ideas would be appreciated.

    - Scott
     
  4. adapter

    adapter Well-Known Member
    PartnerNOC

    Joined:
    Sep 17, 2003
    Messages:
    391
    Likes Received:
    0
    Trophy Points:
    16
    prefork: server reached --max-clients setting, consider raising it

    Go to WHM / cPanel xx.x.x-xxx / Addon Modules, and install spamdconf. Close your WHM, and reopen it again. You will find the menu 'Setup Spamd Startup Configuration' at the bottom of the left menu. Change the Maximum Children to suitable your need. Mine set it to 10.


    url: http://www.rvskin.com/index.php?page=public/antispam
     
  5. mambovince

    mambovince Well-Known Member

    Joined:
    Jan 15, 2005
    Messages:
    192
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    London, UK
    I am having similar problems with services failing on a regular basis, but system admin has just advised reducing these:


    So which is correct, to reduce or increase?? :confused:

    - Vince
     
  6. raystrach

    raystrach Member

    Joined:
    Aug 21, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    keep children small

    i have been having trouble with the server crashing for no apparent reason. in my search for answers i found this page

    Troubleshooting Memory Usage - RimuHosting

    it recommends that you keep the settings as follows...
    max-children 1

    because of multi threading, the spam assassin processes can use up quite a lot of memory. it evidently works quite well with just one thread.

    now that i know how to reset it, i will give it a try to see if things improve

    hope this helps someone
     
Loading...

Share This Page