The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SPAM mail, weird problem.

Discussion in 'E-mail Discussions' started by Meinl, Aug 12, 2013.

  1. Meinl

    Meinl Member

    Joined:
    Jul 3, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi guys,

    I'm having a problem using these tools to generate emails (swiftmailer and PHP mail()).

    When i use scripts to generate automatic emails, them are going direct to spam folder (gmail, hotmail), but when i send emails from existing accounts (i.e through roundcube), i have no problem.

    I've checked the original message and i found this, but i don't know if cause of it. Anyway, could help.

    The difference between a inbox folder and spam folder (sent from same domain) is the following line:

    First, an INBOX message:

    Code:
    X-Get-Message-Sender-Via: [I]HOSTNAME[/I]: authenticated_id: xxxx@domain.com
    Now, the SPAM message:

    Code:
    X-Get-Message-Sender-Via: [I]HOSTNAME[/I]: authenticated_id: domain/from_h
    I need some help, please.

    Thanks and greetings.
     
    #1 Meinl, Aug 12, 2013
    Last edited: Aug 12, 2013
  2. ThinIce

    ThinIce Well-Known Member

    Joined:
    Apr 27, 2006
    Messages:
    346
    Likes Received:
    7
    Trophy Points:
    18
    Location:
    Disillusioned in England
    cPanel Access Level:
    Root Administrator
    For this as well as other reasons, it's sometimes best to use SMTP auth details within your scripts to a legitimate email account. Some mail providers de-prioritise or look negatively upon emails generated by scripts under the web server as historically quite often things like proper bounce tracking aren't performed on them.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    If you can configure the mailer to use SMTP and authenticate with SMTP AUTH, this will set a "Return-Path" in the headers that the remote mail server may view as legitimate instead of SPAM.

    Thank you.
     
  4. Meinl

    Meinl Member

    Joined:
    Jul 3, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks for your answers guys.

    How can i do that?. I need to create a email account and put on my script the same account as From field?.
    What did you mean with configure mailer? (to set SMTP AUTH).

    Really thanks.

    Greetings.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You will need to consult with the support or developer for the script you are using to see if it's possible to use SMTP Authentication. Simply entering a valid email account in the "FROM" field does not enable SMTP authentication.

    Thank you.
     
  6. Meinl

    Meinl Member

    Joined:
    Jul 3, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Michael,

    I followed those instructions but nothing happens. We've set up correctly the SMTP AUTH, and now the original message appears to be OK:

    Code:
    X-Get-Message-Sender-Via: HOSTNAME: authenticated_id: xxxx@domain.com
    but emails still coming to SPAM folder.

    Any ideas?.

    Thank you again.

    Greets.
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    There are several potential reasons why a remote mail server may detect a message as SPAM. Check to make sure RDNS is configured for the IP address used to send email. Also, ensure you have added a SPF record for the domain name.

    Thank you.
     
  8. Meinl

    Meinl Member

    Joined:
    Jul 3, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Michael,

    I've tried many options to solve this subject but without success.

    I have checked up settings and all it's fine.

    The thing is about mail sent through php scripts, because are delivered as SPAM. When i send messages trough server or mail manager, i'm having no problem.

    Could be a configuration problem?, maybe i'm ignoring some config from WHM.

    Thanks.
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I recommend consulting with the support for the remote mail server to find the specific reason your emails are marked as SPAM. It's possible they target emails coming from PHP scripts as SPAM automatically.

    Thank you.
     
Loading...

Share This Page