The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spam not recognized by Filter

Discussion in 'General Discussion' started by jhobbs, Mar 4, 2004.

  1. jhobbs

    jhobbs Member

    Joined:
    Feb 3, 2003
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sturgis, Michigan
    The email filtering in cPanel's 8.8.0-RELEASE 73 shows:
    Hint: To filter all mail that SpamAssasin has marked as spam, just choose "SpamAssassin Spam Header", "begins with", and then enter "Yes" in the box.

    I've configured SpamAssassin to rewrite the header, and used the above hint plus using the text of the rewritten header, so the filter can delete the spam.

    The spam gets moved into NeoMail's SPAM folder. but not deleted. What am I missing?
     
  2. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Try switching off the SPAM folder option which is available with spamassassin and check.

    I usually prefer using spamassassin's option of rewriting the subject by adding "*******SPAM*******" and then using a filter to check is any subject begins with the test, then delete it. Helped me when i used to use it (now i have rbl check and have disabled spamd as it takes lot of cpu resources as we get heavy mail traffic on our boxes).
     
  3. jhobbs

    jhobbs Member

    Joined:
    Feb 3, 2003
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sturgis, Michigan
    Re: Re: Spam not recognized by Filter

    Thanks Anand,
    I couldn't find this SPAM folder option in cPanel's Spamassassin or Email options. Is there another way?
     
  4. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Re: Re: Re: Spam not recognized by Filter

    Its inside the user cpanel. Which theme you using ? Check the spamassain page in default / X theme, it should have it. Let me check and revert back on this.
     
  5. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    alrite X theme, Mail -> Spam Assassin, Enable Spam Box

    Just next to Spam Assassin. Try to switch it off if its turned on.
     
  6. jhobbs

    jhobbs Member

    Joined:
    Feb 3, 2003
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sturgis, Michigan
    That was too obvious. Many thanks!
     
  7. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    np :D

    Surely post here what actually happened. The post might help someone else to solve his probs ;)
     
  8. jhobbs

    jhobbs Member

    Joined:
    Feb 3, 2003
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sturgis, Michigan
    Still no joy! Spam is now coming to my mailbox, not going to the spam folder, but it's not being deleted by the filter.
     
  9. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    hmm... that is strange.

    Btw did you try what i said about using the rewriting the subject and using filter to delete based on subject ??
     
  10. jhobbs

    jhobbs Member

    Joined:
    Feb 3, 2003
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sturgis, Michigan
    Yes. Spamassassin is adding "JBHSPAM" to the headers.
    The filters have

    Filter Destination
    $h_X-Spam-Status: begins "JBHSPAM" Discard
    $h_X-Spam-Status: begins "Yes" Discard
    $header_subject: begins "JBHSPAM" Discard
    $header_subject: contains "JBHSPAM" Discard

    I just added the last one, hoping it would fix something.
    The email subject does begin "JBHSPAM" but the delete filters aren't catching it.
     
  11. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Ok do this in shell.

    mail -v youremail@domain.com
    Subject: JBHSPAM Something now
    test
    .

    And see what happens, does this mail get deliver ?

    Try to open the /etc/vfilters/domain.com and see if the filters are present there.
     
  12. jhobbs

    jhobbs Member

    Joined:
    Feb 3, 2003
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sturgis, Michigan
    Unfortunately, I'm on a VDS and mail is apparently stripped. I tried using pine, but got an abort error message when sending.
    I sent the message using Outlook, cc'd to another email, and the filter worked. So, it appears SpamAssassin is changing the subject, and the filters catch the email when sent from outside, but the filters don't work after SpamAssassin has modified the header.

    The folder you mentioned contains the file with the filter text.
     
  13. jhobbs

    jhobbs Member

    Joined:
    Feb 3, 2003
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sturgis, Michigan
    In case anyone follows this thread, Here is the answer to the problem.
     
Loading...

Share This Page