Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Spam Score almost always blank

Discussion in 'E-mail Discussion' started by tudorh, Apr 4, 2018.

  1. tudorh

    tudorh Member

    Joined:
    Dec 9, 2004
    Messages:
    21
    Likes Received:
    2
    Trophy Points:
    153
    Hi,

    I've searched through all the forums and I can't find an explanation for this from my mail delivery report. Almost all the Spam Scores are blank, and those that aren't are "0".

    Apache Spamassassin is enabled and monitored in Home > Service Configuration > Service Manager.

    Apache Spamassassin service as well as exim, etc, has been restarted.

    In Tweak settings Enable Apache SpamAssassin™ spam filter is ON

    In Exim Configuration Manager, Apache SpamAssassin™: Forced Global ON is ON

    From the console, spamd appears to be running:

    Code:
    root@server [/root]# ps aux|grep spamd
    
    root     10427  1.2  2.5 218588 103380 ?       Ss   00:47   0:08 /usr/local/cpanel/3rdparty/perl/524/bin/perl -T -w /usr/local/cpanel/3rdparty/bin/spamd --max-spare=1 --max-children=3 --allowed-ips=127.0.0.1,::1 --pidfile=/var/run/spamd.pid --listen=5 --listen=6
    
    root     10648  0.2  2.4 219900 98680 ?        S    00:51   0:00 spamd child
    
    root     11300  0.0  0.0 103380  2032 pts/0    R+   00:58   0:00 grep spamd
    
    

    Why else might the spam score be blank all the time?
     

    Attached Files:

  2. tudorh

    tudorh Member

    Joined:
    Dec 9, 2004
    Messages:
    21
    Likes Received:
    2
    Trophy Points:
    153
    Support ticket logged: #9414265
     
  3. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    2,230
    Likes Received:
    161
    Trophy Points:
    143
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @tudorh

    Thank you for including the support ticket ID. I checked the ticket and it would appear that the issue with SpamAssassin was caused by a networking or firewall issue, specifically an inability for exim to communicate with spamd as a result of a customization or modification. The connection from the server's local IP address was not being recognized.

    In order to resolve this, the analyst added the server's local IP to WHM » Spamd Startup Configuration » "Allowed IPs" section

    Thank you,
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice