The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spamassasin Filter not working

Discussion in 'E-mail Discussions' started by amitkalra, Apr 4, 2016.

  1. amitkalra

    amitkalra Member

    Joined:
    Mar 9, 2006
    Messages:
    13
    Likes Received:
    1
    Trophy Points:
    3
    Hi

    I have a dedicated Server with root access.
    • CENTOS 6.7 x86_64 standard – exl
    • WHM 54.0 (build 21)
    • spamd 3.4.1
    • exim-4.86.1-2.cp1154.x86_64
    From 31st March onwards I noticed the incoming mails did not have the X-Spam headers.
    When we looked at the Spamassasin logs it seems the mails were not filtered through Spam Assasin at all after 31st March.

    I have double checked in Server Configuration - Tweek Settings "Enable Apache SpamAssassin™ spam filter" is set to on.

    In Exim Configuration I have set Apache SpamAssassin™: Forced Global ON [?] to On to make sure Spamassasin is enabled for all users. In Cpanel for users it is showing as enabled for all.

    We have restarted spamd and exim services a number of times and they are working fine.

    Here I would like to add I made the following changes to Exim on 31st March but I don't think theses would have caused Spamassassin Filter to be bypassed. These changes were made to prevent outgoing spam, and to prevent spoofing for outgoing mails.

    Changes made on 31st March
    1. EXPERIMENTAL: Rewrite From: header to match actual sender [?] - Set to Remote.
    2. I implemented these custom settings to prevent for Authenticated spoof mails for outgoing mails. This is working. Now outgoing mails get rejected if the sender account and the email address are different.
    bobcares.com/blog/blocking-spoofed-mails-going-out-of-your-cpanel-whm-web-hosting-server/
    Blocking spoofed mails going out of your cPanel/WHM web hosting server - Bobcares

    I had taken backups of exim configuration files on 21st March and before making these changes on 31st March 2016. I restored both of these configurations, restarted exim, and spamd but still Mail was not going through the Spamassasin Filter.

    Any ideas what else I can check ?


    Thanks
    Amit

    Update : I have created a ticket about this with Cpanel Support. They are looking at it.
    I will update this thread about the outcome.
     
    #1 amitkalra, Apr 4, 2016
    Last edited: Apr 4, 2016
  2. amitkalra

    amitkalra Member

    Joined:
    Mar 9, 2006
    Messages:
    13
    Likes Received:
    1
    Trophy Points:
    3
    Update - Problem is resolved and Spamassassin is checking mails again.
    Here is a quote from the Cpanel Support person, on what was done to fix it.

     
    #2 amitkalra, Apr 4, 2016
    Last edited by a moderator: Apr 5, 2016
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page