The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spamassasin Woes

Discussion in 'General Discussion' started by kris1351, Nov 22, 2004.

  1. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    We have one server that is giving us fits with SA. I run the installspam and fixspamassainfailedupdate scripts and everything will work great for 24-48 hours then suddenly no headers will be written until I run the two scripts again. We have auto-updates off except for sysup on upcp. Anyone else having an issue like this?
     
  2. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    I have seen a few cases where spamd dies and the results are similar to what you mentioned. Generally, though, simply restarting exim solves that problem, so I am not sure that we are on the same page with that.

    What version of Exim? It was a problem for me a bit ago, but it seems to have cleared itself up lately, so perhaps there is an update you might consider applying.
     
  3. heyjohnboy

    heyjohnboy Well-Known Member

    Joined:
    Oct 7, 2003
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Valencia, CA
    We've been having the same problem since our last whm/cpanel upgrade (to 9.9.7 / 9.9.8 stable 6).

    We haven't tried it yet, but this looked interesting:

    http://forums.cpanel.net/showthread.php?t=32445

    Please let us know if you find a permanent fix for this. Clients are not happy with the huge increase in spam.
     
  4. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    When the headers are no longer getting written, do you have processes called spam child in your ps list?
     
  5. heyjohnboy

    heyjohnboy Well-Known Member

    Joined:
    Oct 7, 2003
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Valencia, CA
    We just checked... and yes, we do.
     

Share This Page