The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SpamAssassin 3.1.0 issues. again

Discussion in 'General Discussion' started by gupi, Sep 28, 2005.

  1. gupi

    gupi Well-Known Member

    Joined:
    Apr 27, 2004
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    16
    INITIAL FACTS:
    - CentOS 3.5 server, cPanel RELEASE (in the meantime I've switched to STABLE)
    - SPAM+Antivirus procedures implemented like in http://www.rvskin.com/index.php?page=public/antispam document.

    ISSUES
    After upgrading to SA 3.1.0 I've noticed a lot of spam passing through, along with the lack of X-Spam headers added to all messages by SA.

    SOLUTIONS TRIED:
    - switched to perl 5.8.7, updated all needed modules; no luck, switched back
    - activated Razor and DCC in SA (default are inactive); no luck;

    ISSUES REMAINING
    * spamd runs as root; so, I have errors like the one described in http://www.gossamer-threads.com/lists/spamassassin/users/60505
    Since the reccomendations are NOT to run spamd as root, please advice where can I pass the user options for clamd daemon (what script needs to be modified);
    * if the message is *not* spam, no X-Spam headers are attached, although I've set this option in /etc/mail/spamassassin/local.cf, using "add_header all ...." option.

    Does anybody still have these issues ?

    Thank you,
     
  2. DavidR

    DavidR Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    On my server, spamd and clamd show up running as root and as users. I had never thought about it before but now I'm curious.

    David
     
  3. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    Same here. We are having nothing but headaches with SA 3.0.1 and its really screwed up our MailScanner installation too. Also alot of pharmacutical spam getting through now.
     
  4. gupi

    gupi Well-Known Member

    Joined:
    Apr 27, 2004
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    16
    Well, here's a small update I've managed to resolve:
    Regarding the [root] user issue, do like this (in ssh, as root user):

    1) create a folder [spamassassin] in /var/spool
    # mkdir /var/spool/spamassassin

    2) copy all files from /root/.spamassassin to the new created folder
    # cp /root/.spamassassin/* /var/spool/spamassassin

    3) set proper permissions and owners
    # chown mailnull.mailnull /var/spool/spamassassin/*
    # chmod 0666 /var/spool/spamassassin/*
    # chmod 0755 /var/spool/spamassassin

    (this step needs attention, is based on my local settings and may vary)


    4) add the following lines into /etc/mail/spamassassin/local.cf
    ##### new location for files
    auto_whitelist_path /var/spool/spamassassin/auto_whitelist
    bayes_path /var/spool/spamassassin/bayes
    bayes_file_mode 777
    ##### new location for files

    5) restart exim
    # /scripts/restartsrv_exim

    6) watch the logs for spamd
    # tail -f /var/log/messages | grep spamd

    now, at least shouldn't have any errors related to permission for various spam and bayes files.

    Please note that although worked for me, there are NO WARANTIES it will work in your case.
    Start do this only if you know what you are doing. You are at your own risk.
     
Loading...

Share This Page