The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SpamAssassin 3.1.0 Not working right?

Discussion in 'General Discussion' started by GOT, Sep 18, 2005.

  1. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    I noticed we got an update to SpamAssassin. I was looking at my headers adn they indicated 3.0.4, but when I did spamd -V it returned 3.1.0.

    So, I restarted exim.

    Now spamassassin is not adding the headers to the emails at all. Alsy there are only two children processes instead of the 4 I normally see.

    Spamassassin does work a little bit, because if I send a gtube, spam assassin catches it at the MTA level and rejects it (not normal behavior, something I added with the assistance of rvskin.com)

    The log show virtual_sa_delivery, but there are no headers indicating the spam score.

    Anyone else seeing this/have a fix for it?

    Jon
     
  2. Ken H

    Ken H Member

    Joined:
    Apr 12, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Newest Update Breaks Spamassassin!!!!!

    WHM 10.6.0 cPanel 10.8.0-S15
    RedHat 9 i686 - WHM X v3.1.0

    Starting some time in the last day. Any account with SpamAssasin Turned on.. just bounces email. All email accounts on the account with SA enabled bounce email.

    The second it is turned off. Email works again.

    I have had to go in and turn it off on client accounts VERY SERIOUS PROBLEM!!!!!! :eek:
     
  3. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    This is what I get when I do a -V. My SA is working fine ..but I bet I will have problems if I restart exim.



    root@mybox [~]# spamd -V
    SpamAssassin Server version 3.1.0
    running on Perl 5.8.6
    [3548] error: Can't locate IO/Socket/SSL.pm in @INC (@INC contains: ../lib /usr/lib/perl5/site_perl/5.8.6/i686-linux /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/5.8.6/i686-linux /usr/lib/perl5/5.8.6 /usr/lib/perl5/site_perl/5.8.1/i686-linux /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl) at /usr/bin/spamd line 102.
     
  4. Myacen

    Myacen Well-Known Member

    Joined:
    Apr 6, 2002
    Messages:
    222
    Likes Received:
    0
    Trophy Points:
    16
    spamd -V
    SpamAssassin Server version 3.1.0
    running on Perl 5.8.7
    with SSL support (IO::Socket::SSL 0.97)
     
  5. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA

    take a look at come headers and see what version you see listed.
     
  6. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    i updated perl on my boxes and restarted exim with new spamd and headers report new version and seem to be scoring now ok.
     
  7. Ken H

    Ken H Member

    Joined:
    Apr 12, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    root@vps [/home/xhost]# spamd -V
    SpamAssassin Server version 3.1.0
    running on Perl 5.8.1
    [4256] error: Can't locate IO/Socket/SSL.pm in @INC (@INC contains: ../lib /usr/lib/perl5/site_perl/5.8.1/i686-linux /usr/lib/
    perl5/site_perl/5.8.1 /usr/lib/perl5/5.8.1/i686-linux /usr/lib/perl5/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_
    perl) at /usr/bin/spamd line 102.

    I have run all the updates I know of in WHM.
    What should I do to get this fixed?

    Thanks
     
  8. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA

    Try bumping up perl to 5.8.7 .That fixed it for me.
     
  9. Ken H

    Ken H Member

    Joined:
    Apr 12, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I fixed it by installing the IO::Sockets Perl Mod missing in the Error DUH!!!
    Slap me...HARD :)
     
  10. gupi

    gupi Well-Known Member

    Joined:
    Apr 27, 2004
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    16
    Code:
    user@bravo [/home]# spamd -V
    SpamAssassin Server version 3.1.0
      running on Perl 5.8.6
      with SSL support (IO::Socket::SSL 0.97)
    user@bravo [/home]#
    Still no X-Spam headers for usual messages, SpamAssassin adds them only for messages above the treshold.
    (Same situation with perl 5.8.7, too).

    Any ideas ?
     
  11. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Try
    /scripts/perlinstaller IO::Socket::SSL
     
  12. gupi

    gupi Well-Known Member

    Joined:
    Apr 27, 2004
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    16
    Been there, done that:
    * spamassassin -D --lint gave me 4 errors, I had to disable razor and dcc in local.cf
    * GTUBE test message is filtered OK, but spam usually gets through SA
    * SA does not add X-Spam headers to all messages, like it use to do

    Anyone in this situation ?
     
  13. neutro

    neutro Well-Known Member

    Joined:
    Apr 11, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    DCC and Razor

    check /etc/mail/spamassassin/v31o.pre

    uncomment #
    loadplugin Mail::SpamAssassin::Plugin::DCC
    loadplugin Mail::SpamAssassin::Plugin::Razor2
    the new spam assasin disable dcc and razor by default

    SPAM Header

    check


    /etc/mail/spamassassin/local.cf

    rewrite_header Subject ****SPAM(_SCORE_)****
     
    #13 neutro, Sep 27, 2005
    Last edited: Sep 27, 2005
  14. PanelGuy

    PanelGuy Well-Known Member

    Joined:
    Oct 13, 2004
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    Similar but not exactly

    I'm having a similar problem.

    The problem is that no one on the server can get email from outside the server, only from users on the server.

    Anyone seen this before and know what's causing it?

    Any help or ideas would be GREATLY appreciated!
     
    #14 PanelGuy, Sep 28, 2005
    Last edited: Sep 28, 2005
  15. wallyfoo

    wallyfoo Registered

    Joined:
    Dec 3, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Similar behavior with spamd -V 3.1.7

    Turning off the spamassassin option allows mail through. Turning on spamassassin bounces everything.
     
  16. shivamxp

    shivamxp Well-Known Member

    Joined:
    Jan 30, 2005
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Fix:

    GO to WHM Settings

    Verify the existence of email senders.
    Use callouts to verify the existence of email senders.

    UNTICK BOTH.

    Restart pop and exim.

    Keep spamassasin on.

    Try now. works for me ...weird how cpanel has issues with spamassasin OR is it that the verify existing senders doenst understand HOTMAIL / YAHOO / REDIFF n others are real senders :(

    weird...
     
Loading...

Share This Page