SpamAssassin blocking all mail

CWIMike

Member
Jul 27, 2002
5
0
151
Since today's updates, any accounts with SpamAssassin enabled are not having any mail delivered to them. The exim_mainlog says that mail is being delivered, but the mail itself cannot be found.

Disabling SpamAssassin allows mail to be sent, and the accounts without SpamAssassin have had no problems.

Any ideas?
 

Wallaby

Well-Known Member
Aug 15, 2001
131
1
318
I'm getting exactly the same:

- When I was on Build 12, with Spam Assassin enabled all mail was getting bounced back to the sender.

- With S. A. disabled, all works fine.

- I tried /scripts/convertemails5 and it had no effect.

- Just a few mins ago did /scripts/upcp to manually update CPanel, which has taken me to Build 18.

- Now, with S. A. enabled, all mail just disappears -- it does not even get bounced back.

This last is the same problem that existed a long time ago and eventually got fixed, and allowed us to use Spam Assassin.

Sure hope that you can fix this asap, we get tons and tons of spam!
 

jumpdomain

Well-Known Member
Aug 12, 2001
109
0
316
Yes, we are seeing this also... All emails are gone.

If anyone else wants to disable Spam Assassin on all the users accounts, they can do a:
locate .spamassassinenable

Then remove all the files that show-up from the locate. They will be in the:
/home/$username/.spamassassinenable
Replace $username with the users username.
 

MichaelShanks

Well-Known Member
PartnerNOC
Aug 20, 2001
103
0
316
I beleive i have found the error

pico /etc/exim.conf

search for this line

command = &/usr/bin/spamassassin -l ${extract{5}{:}{${lookup{$local_part}lsearch{/etc/passwd}{$value}}}}/mail/inbox-w

that is the error, mail is being sent to inbox-w

change it to

command = &/usr/bin/spamassassin -l ${extract{5}{:}{${lookup{$local_part}lsearch{/etc/passwd}{$value}}}}/mail/inbox -w

and that should fix it.

I have reported this to nick
 

Wallaby

Well-Known Member
Aug 15, 2001
131
1
318
Hi Mike,

Good to see the Brits sorting things out :)

I tried that, and on a test account it did seem to stop the problem of mail not getting delivered, now Spam Assassin does not seem to be doing any filtering (ie, no Spam Assassin stuff is getting added to the mail headers).
 
B

bdraco

Guest
Actually that won't fix the problem, it will just pass the mail though (that is what th e -l option does)

spamassassin 2.4x broke delivery to mboxs. Actually they just removed it completly (the missing space is a result of trying to get a quick fix .. which doesn't fix it anyways).


I'm actually having to patch up the spamassassin script. FYI, this has nothing to do with cPanel 5 mail, spamassassin just decided to drop mbox deliver support (with no notice) yesterday.
 
B

bdraco

Guest
Running /scripts/sysup exim should install a modified exim.conf what uses this new modified spamassassin (spamassasin-cpanel)
 

rich2

Well-Known Member
Apr 9, 2002
64
0
306
ran the sysup, restarted exim, still getting

This message was created automatically by mail delivery software (Exim).

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

[email protected]
Child process of virtual_sa_userdelivery transport returned 70 (could mean internal software error) from command:
/usr/bin/spamassassin
 
B

bdraco

Guest
[quote:2d771ab3fa][i:2d771ab3fa]Originally posted by rich2[/i:2d771ab3fa]

ran the sysup, restarted exim, still getting

This message was created automatically by mail delivery software (Exim).

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

[email protected]
Child process of virtual_sa_userdelivery transport returned 70 (could mean internal software error) from command:
/usr/bin/spamassassin
[/quote:2d771ab3fa]

Do you have your exim.conf +i ??

It should be delivering to /usr/bin/spamassassin-cpanel
 

rich2

Well-Known Member
Apr 9, 2002
64
0
306
not sure what you mean by +i (chmod +i /etc/exim.conf ?) guess i'm a newb.

but yes the conf looks right, i see the file, and its specified in the conf correctly.

*scratches head*
 

rich2

Well-Known Member
Apr 9, 2002
64
0
306
[root@oxygen ] ~ & grep cpanel /etc/exim.conf
command = &/usr/bin/spamassassin-cpanel -w $sender_address&
command = &/usr/bin/spamassassin-cpanel -w $sender_address&
 

CWIMike

Member
Jul 27, 2002
5
0
151
A quick note: Apparently, the latest build of CPanel (5.0.0-24) fixed the problem, because SpamAssassin's working again for me. YAY! :)

Thanks, CPanel!

Mike
 

rich2

Well-Known Member
Apr 9, 2002
64
0
306
yes i think everything is working fine, did a few tests. we'll see if my customers get to me though :)
 

Brad

Well-Known Member
Aug 16, 2001
229
0
316
They already got to me, been scratching my head for hours till I found this thread.. Ahhhhhh,,

[quote:3e1ded038b][i:3e1ded038b]Originally posted by rich2[/i:3e1ded038b]

yes i think everything is working fine, did a few tests. we'll see if my customers get to me though :)[/quote:3e1ded038b]
 

Wallaby

Well-Known Member
Aug 15, 2001
131
1
318
Whooo hooo! We're filtering spam again -- re-enabled SA on our main account and it's now all fine and dandy.

Thanks for sorting this, much appreciated.
 

dzevad

Well-Known Member
Oct 7, 2001
94
0
306
Is this new exim-spamassassin combination going to work ok for domains where spamassassin used to go crazy and make huge load on server and reject mail?
About 15 days ago I had to disable spamassassin on accounts with more than 30 email since it used to go crazy.

Does this combination fix that too?

Thanks
 
B

bdraco

Guest
[quote:3a9fb1c409][i:3a9fb1c409]Originally posted by dzevad[/i:3a9fb1c409]

Is this new exim-spamassassin combination going to work ok for domains where spamassassin used to go crazy and make huge load on server and reject mail?
About 15 days ago I had to disable spamassassin on accounts with more than 30 email since it used to go crazy.

Does this combination fix that too?

Thanks[/quote:3a9fb1c409]

The spamassassin rewrote a larger portion of their code (have to love them for just down right removing mbox delivery support) so I hope everything will be quite a bit more stable now.
 

dzevad

Well-Known Member
Oct 7, 2001
94
0
306
[quote:52f790f14f][i:52f790f14f]Originally posted by bdraco[/i:52f790f14f]

The spamassassin rewrote a larger portion of their code (have to love them for just down right removing mbox delivery support) so I hope everything will be quite a bit more stable now.[/quote:52f790f14f]

I just checked and I still have SpamAssassin version 2.31, and on their site there is 2.41 , were you refering ro 2.31 or 2.41?

And does Cpanel updates Spamassassin too?

Thanks