The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SpamAssassin blocking all mail

Discussion in 'E-mail Discussions' started by CWIMike, Sep 10, 2002.

  1. CWIMike

    CWIMike Member

    Joined:
    Jul 27, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Since today's updates, any accounts with SpamAssassin enabled are not having any mail delivered to them. The exim_mainlog says that mail is being delivered, but the mail itself cannot be found.

    Disabling SpamAssassin allows mail to be sent, and the accounts without SpamAssassin have had no problems.

    Any ideas?
     
  2. Wallaby

    Wallaby Well-Known Member

    Joined:
    Aug 15, 2001
    Messages:
    131
    Likes Received:
    1
    Trophy Points:
    18
    I'm getting exactly the same:

    - When I was on Build 12, with Spam Assassin enabled all mail was getting bounced back to the sender.

    - With S. A. disabled, all works fine.

    - I tried /scripts/convertemails5 and it had no effect.

    - Just a few mins ago did /scripts/upcp to manually update CPanel, which has taken me to Build 18.

    - Now, with S. A. enabled, all mail just disappears -- it does not even get bounced back.

    This last is the same problem that existed a long time ago and eventually got fixed, and allowed us to use Spam Assassin.

    Sure hope that you can fix this asap, we get tons and tons of spam!
     
  3. jumpdomain

    jumpdomain Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    16
    Yes, we are seeing this also... All emails are gone.

    If anyone else wants to disable Spam Assassin on all the users accounts, they can do a:
    locate .spamassassinenable

    Then remove all the files that show-up from the locate. They will be in the:
    /home/$username/.spamassassinenable
    Replace $username with the users username.
     
  4. MichaelShanks

    MichaelShanks Well-Known Member
    PartnerNOC

    Joined:
    Aug 20, 2001
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    I beleive i have found the error

    pico /etc/exim.conf

    search for this line

    command = &/usr/bin/spamassassin -l ${extract{5}{:}{${lookup{$local_part}lsearch{/etc/passwd}{$value}}}}/mail/inbox-w

    that is the error, mail is being sent to inbox-w

    change it to

    command = &/usr/bin/spamassassin -l ${extract{5}{:}{${lookup{$local_part}lsearch{/etc/passwd}{$value}}}}/mail/inbox -w

    and that should fix it.

    I have reported this to nick
     
  5. Wallaby

    Wallaby Well-Known Member

    Joined:
    Aug 15, 2001
    Messages:
    131
    Likes Received:
    1
    Trophy Points:
    18
    Hi Mike,

    Good to see the Brits sorting things out :)

    I tried that, and on a test account it did seem to stop the problem of mail not getting delivered, now Spam Assassin does not seem to be doing any filtering (ie, no Spam Assassin stuff is getting added to the mail headers).
     
  6. bdraco

    bdraco Guest

    Actually that won't fix the problem, it will just pass the mail though (that is what th e -l option does)

    spamassassin 2.4x broke delivery to mboxs. Actually they just removed it completly (the missing space is a result of trying to get a quick fix .. which doesn't fix it anyways).


    I'm actually having to patch up the spamassassin script. FYI, this has nothing to do with cPanel 5 mail, spamassassin just decided to drop mbox deliver support (with no notice) yesterday.
     
  7. bdraco

    bdraco Guest

    Running /scripts/sysup exim should install a modified exim.conf what uses this new modified spamassassin (spamassasin-cpanel)
     
  8. rich2

    rich2 Well-Known Member

    Joined:
    Apr 9, 2002
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    ran the sysup, restarted exim, still getting

    This message was created automatically by mail delivery software (Exim).

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    user@domain.com
    Child process of virtual_sa_userdelivery transport returned 70 (could mean internal software error) from command:
    /usr/bin/spamassassin
     
  9. bdraco

    bdraco Guest

    [quote:2d771ab3fa][i:2d771ab3fa]Originally posted by rich2[/i:2d771ab3fa]

    ran the sysup, restarted exim, still getting

    This message was created automatically by mail delivery software (Exim).

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    user@domain.com
    Child process of virtual_sa_userdelivery transport returned 70 (could mean internal software error) from command:
    /usr/bin/spamassassin
    [/quote:2d771ab3fa]

    Do you have your exim.conf +i ??

    It should be delivering to /usr/bin/spamassassin-cpanel
     
  10. rich2

    rich2 Well-Known Member

    Joined:
    Apr 9, 2002
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    not sure what you mean by +i (chmod +i /etc/exim.conf ?) guess i'm a newb.

    but yes the conf looks right, i see the file, and its specified in the conf correctly.

    *scratches head*
     
  11. bdraco

    bdraco Guest

    please run

    grep cpanel /etc/exim.conf
     
  12. rich2

    rich2 Well-Known Member

    Joined:
    Apr 9, 2002
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    [root@oxygen ] ~ & grep cpanel /etc/exim.conf
    command = &/usr/bin/spamassassin-cpanel -w $sender_address&
    command = &/usr/bin/spamassassin-cpanel -w $sender_address&
     
  13. CWIMike

    CWIMike Member

    Joined:
    Jul 27, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    A quick note: Apparently, the latest build of CPanel (5.0.0-24) fixed the problem, because SpamAssassin's working again for me. YAY! :)

    Thanks, CPanel!

    Mike
     
  14. rich2

    rich2 Well-Known Member

    Joined:
    Apr 9, 2002
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    yes i think everything is working fine, did a few tests. we'll see if my customers get to me though :)
     
  15. Brad

    Brad Well-Known Member

    Joined:
    Aug 16, 2001
    Messages:
    231
    Likes Received:
    0
    Trophy Points:
    16
    The /scripts/sysup fixed the problem here..
     
  16. Brad

    Brad Well-Known Member

    Joined:
    Aug 16, 2001
    Messages:
    231
    Likes Received:
    0
    Trophy Points:
    16
    They already got to me, been scratching my head for hours till I found this thread.. Ahhhhhh,,

    [quote:3e1ded038b][i:3e1ded038b]Originally posted by rich2[/i:3e1ded038b]

    yes i think everything is working fine, did a few tests. we'll see if my customers get to me though :)[/quote:3e1ded038b]
     
  17. Wallaby

    Wallaby Well-Known Member

    Joined:
    Aug 15, 2001
    Messages:
    131
    Likes Received:
    1
    Trophy Points:
    18
    Whooo hooo! We're filtering spam again -- re-enabled SA on our main account and it's now all fine and dandy.

    Thanks for sorting this, much appreciated.
     
  18. dzevad

    dzevad Well-Known Member

    Joined:
    Oct 7, 2001
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    6
    Is this new exim-spamassassin combination going to work ok for domains where spamassassin used to go crazy and make huge load on server and reject mail?
    About 15 days ago I had to disable spamassassin on accounts with more than 30 email since it used to go crazy.

    Does this combination fix that too?

    Thanks
     
  19. bdraco

    bdraco Guest

    [quote:3a9fb1c409][i:3a9fb1c409]Originally posted by dzevad[/i:3a9fb1c409]

    Is this new exim-spamassassin combination going to work ok for domains where spamassassin used to go crazy and make huge load on server and reject mail?
    About 15 days ago I had to disable spamassassin on accounts with more than 30 email since it used to go crazy.

    Does this combination fix that too?

    Thanks[/quote:3a9fb1c409]

    The spamassassin rewrote a larger portion of their code (have to love them for just down right removing mbox delivery support) so I hope everything will be quite a bit more stable now.
     
  20. dzevad

    dzevad Well-Known Member

    Joined:
    Oct 7, 2001
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    6
    [quote:52f790f14f][i:52f790f14f]Originally posted by bdraco[/i:52f790f14f]

    The spamassassin rewrote a larger portion of their code (have to love them for just down right removing mbox delivery support) so I hope everything will be quite a bit more stable now.[/quote:52f790f14f]

    I just checked and I still have SpamAssassin version 2.31, and on their site there is 2.41 , were you refering ro 2.31 or 2.41?

    And does Cpanel updates Spamassassin too?

    Thanks
     
Loading...

Share This Page