The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spamassassin/exim routing issue

Discussion in 'General Discussion' started by JustinK, Aug 28, 2003.

  1. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    Can someone run a test on their systems if they have a new release?

    Steps:

    1. Create an email account on a domain which doesn't have spamassassin enabled. Make sure the first part of the address is the same as the username for a cpanel account which does have spamassassin enabled.

    2. Send an e-mail to the new address and see if spamassassin is processing the email even though it shouldn't be.


    EX:
    1. Created teddy@domain-X.com
    domain-X.com does not have spamassassin enabled.
    teddy is the username for an account on the server called teddytimes.com which does have spamassassin enabled.

    2. E-mailed teddy@domain-X.com which shouldn't be filtered through Spamassassin, to find spamassassin has gotten ahold of it and added info.

    I'm doing additional testing myself and will attempt to send another ticket in to darkorb later (it said the server IP wasn't licensed), but I want to see if this is happening on other servers. Also, please state which cpanel version you tried this with. Thanks for your time to any who run this test. :)

    cPanel.net Support Ticket Number:
     
  2. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    I don't suppose anyone had a chance to test this?

    cPanel.net Support Ticket Number:
     
  3. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Change the sa_localuser router to

    sa_localuser:
    driver = accept
    check_local_user
    domains = ! lsearch;/etc/userdomains
    headers_add="${perl{gensaheader}{$local_part}}"
    condition = "${perl{checkusersa}{$local_part}{$received_protocol}}"
    transport = local_sa_delivery


    This should correct it.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page