The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spamassassin Failed.

Discussion in 'E-mail Discussions' started by Powercore, Jun 2, 2008.

  1. Powercore

    Powercore Registered

    Joined:
    Jun 20, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Every night around midnight, spamassassin breaks - I get bombarded with emails telling me, I can run exim restart and get an error (unfortunately dont have a copy at this time - but if this isn't a known issue, I shall post it tomorrow).

    It's to do with SpamassassinSandbox.pm or something similar not being found.

    I fix it by running /scripts/perlinstaller --force Mail::SpamAssassin then running an exim restart, everything works fine for the rest of the day, until around midnight again, and again it happens.

    I've also tried the fix_sa_compile etc to no avail.

    any ideas?

    Should have added:

    WHM 11.15.0 cPanel 11.18.3-R21703

    SpamAssassin Server version 3.2.4
    running on Perl 5.8.8
    with SSL support (IO::Socket::SSL 1.13)
    with zlib support (Compress::Zlib 2.005)
     
  2. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Europe
    I had that happen when i disabled upcp updates from WHM, for some reason that breaks SA in my systems.

    I believe the scripts don't take my options into consideration and try to update SA anyway, which breaks.
     
  3. Powercore

    Powercore Registered

    Joined:
    Jun 20, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Yes, this seems to be the case - as I also have automatic updates disabled.
     
  4. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Europe
    its a *feature*.... ;)

    see? you aren't supposed to disable updates... Big Brother v1.0 should always be kept updated with the latest spyware modules ;)
     
  5. Powercore

    Powercore Registered

    Joined:
    Jun 20, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Letting it update whenever it feels like caused more problems than just spamassassin breaking, so I won't be re-enabling it.
     
  6. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    You'll need to update to 11.23 fully. This is indicative of /scripts being update, but not /usr/local/cpanel
     
  7. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    cPanel 11.23 also has logic that older version did not to prevent third party scripts and addons from triggering an update when updates are set to 'never'.
     
Loading...

Share This Page