The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SpamAssassin/Horde question

Discussion in 'cPanel Developers' started by roenick92, Nov 6, 2006.

  1. roenick92

    roenick92 Registered

    Jun 6, 2006
    Likes Received:
    Trophy Points:
    Hello- I'm trying to get spamassassin working to try to put a dent in the overflow of spam mail. So far, I can't set it up in Horde, and I've looked all over for the answer, but no dice- here's my setup:

    WHM 10.8.0 cPanel 10.9.0-R57
    CentOS 4.4 i686 - WHM X v3.1.0
    Horde: 3.1.3
    Imp: H3 (4.1.3)
    Ingo: H3 (1.1.1)
    Jonah: 0.1-cvs
    Kronolith: H3 (2.1.2)
    Mnemo: H3 (2.1)
    Nag: H3 (2.1.1)
    Turba: H3 (2.1.2)
    PHP Version: 4.4.2

    Spamassassin is enabled, and despite the spam Horde works great. The ability to mark a new email as spam/ham is not enabled, so there's no way for each user to train SA. I figured logging in under the horde administration section would give me the ability to set this up, but when I go there (I added myself to the admin group), clicking on another tab does nothing. When I try through IE, I get the following error when I get into the admin option section for horde:

    Line: 49
    Char: 1
    Error: 'Horde_Form_Sections' is undefined
    Code: 0

    The menu loads, and when I try to click on any other tab, I get this error:

    Line: 52
    Char: 1
    Error: 'sections_configform' is null or not an object
    Code: 0

    I've checked through the horde config faq, but since it was pre-installed with cpanel, it's not much help. The closest thing I could find to my problem had the solution of updating the horde framework, so I tried /scripts/resethorde & /scripts/fullhordereset, and it still gives me the error. It shows the newest version of horde (3.1.3), so I'm pretty stuck. My own personal learn_spam folder is overflowin' and just itchin' to train SA. So I guess my question is how do I get that horde admin menu to work? From there I'll figure out pretty quickly if it is where I need to be to configure horde to work w/ SA.. If anybody has been down this road, knows what to do and could pass it on, I would appreciate it- thanks for your time!
Similar Threads - SpamAssassin Horde question
  1. Kevin Hands

Share This Page