The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

spamassassin not correctly configured

Discussion in 'General Discussion' started by Berbox, Nov 30, 2006.

  1. Berbox

    Berbox Well-Known Member

    Joined:
    Apr 4, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Belgium
    Today i noticed that on all our servers there was no rule active to add the word "SPAM" to the subject.
    I added the line "rewrite_header Subject ***SPAM***" to the global configuration file /etc/mail/spamassassin/local.cf and restarted spamassassin.

    Spamassassin was working correct now only when I enabled the function to delete the mails immediately with "SPAM" in the subject with the link under the menu spamassassin in Cpanel the following filter rule was added.
    Adding filter rule to discard messages with subject was added.
    $header_subject: contains ""​

    Does this delete all emails with a subject?
    When I pushed a second time on the option to delete the SPAM emails the correct rule "$header_subject: contains "SPAM"" was added and also a user.cf file was made in the user map.

    I think there is something wrong with the script that creates the filter rule.
    Also I have to notice that when I added the subject rule to the global configuration file this was not shown in the users spamassassin configuration in Cpanel. Why this is not adapted?

    Can somebody confirm this?
     
  2. mctDarren

    mctDarren Well-Known Member

    Joined:
    Jan 6, 2004
    Messages:
    664
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    New Jersey
    cPanel Access Level:
    Root Administrator
    Edit: Oh, misunderstood post first time. Might have just been a hiccup the first time around when you added the rule. Is it working for you now?

    As for the other problem, try:
    Code:
    rewrite_subject [***SPAM***]
     
    #2 mctDarren, Nov 30, 2006
    Last edited: Nov 30, 2006
  3. Berbox

    Berbox Well-Known Member

    Joined:
    Apr 4, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Belgium
    Hello Webtiva,

    This does not solve the problem. The only thing I adapt manually is the global configuration file. The other entries are made by Cpanel in the menu "Mail" >> "Spamassassin".
     
Loading...

Share This Page