The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SpamAssassin Not Tagging Forwarded Emails

Discussion in 'E-mail Discussions' started by Jeff75, Dec 10, 2003.

  1. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    I have SpamAssassin and SpamBox enabled on an account and for some reason it is not tagging emails that are forwarded to external domain names.

    It should show up with something like:

    X-Spam-Status: No, hits=-4.7 required=5.0 tests=AWL,BAYES_10,HTML_50_60,HTML_FONT_FACE_ODD,REFERENCES version=2.55
    X-Spam-Level:
    X-Spam-Checker-Version: SpamAssassin 2.55 (1.174.2.19-2003-05-19-exp)

    at the bottom of the headers, but for some reason it is not. Can somebody tell me how to get this working for any email that is sent through the account's domain? I've tried restarting Exim but it didn't help.
     
  2. perlchild

    perlchild Well-Known Member

    Joined:
    Sep 1, 2002
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    By default spamassassin doesn't add these headers twice, is it possible your emails were marked already, before the forward?
     
  3. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    perlchild,

    I'm not sure what you mean about adding the headers twice, but there is nothing in the headers that has any reference to SpamAssassin so it seems like it's not working.

    I have a forwarder set up on a cPanel account which forwards to an account with my ISP. When I send a blank email with viagra in the subject and body, the tags above do not show up in the header. When I send an email to an account on another (non cPanel) server that I have which is running Spam Assassin, the SpamAssassin tags show up in the headers.
     
  4. perlchild

    perlchild Well-Known Member

    Joined:
    Sep 1, 2002
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    Ok, it's not what I thought.
    I think I have a few ideas why it wouldn't appear though. When you send, you send authenticated smtp right?
     
  5. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    Yes, that's correct.
     
  6. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    I opened a ticket with cPanel about this and this is what they wrote back:

    SpamAssassin is only invoked for mails headed for local delivery -- a forward to an outside domain is handled internally by Exim and SpamAssassin isn't involved in that process.
     
  7. Daniel

    Daniel Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    165
    Likes Received:
    0
    Trophy Points:
    16
    Here is a workaround that may be of help. If you create a pop3 account with the same email address as the forward spam assassin will mark the forwarded email. Now the only problem with this is now the mail is stored on the server. If you don't want that setup a cron job to delete the inbox.

    A little messy but it gets the job done.
     
  8. Wallaby

    Wallaby Well-Known Member

    Joined:
    Aug 15, 2001
    Messages:
    131
    Likes Received:
    1
    Trophy Points:
    18
    I think this is a change in behaviour as we tested just this scenario some time back and all forwared mail was being passed through SpamAssassin.

    However, we also have found that forwarded mail is no longer being dealt with by SA. Shame.
     
  9. bmcgrail

    bmcgrail Well-Known Member

    Joined:
    Dec 8, 2003
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Howto make spamassasin run against forwarded messages

    By default exim only runs SA against locally delivered messages.

    If you configure MailScanner to run SA it will check ALL messages both local and remote.

    In MailScanner.conf you have to configure:
    Spam Checks = yes
    Use SpamAssassin = yes

    However then SA runs twice for locally delivered messages. I posted a thread on how to make it not run twice at http://forums.cpanel.net/showthread.php?threadid=19534&goto=newpost

    --Ben
     
  10. criss

    criss Registered

    Joined:
    Oct 3, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    It works!!

    Hi,

    I had a similar issue the spam assassin headers were not coming up in the ails.


    Try this.
    ~~~~~~~~~~
    [/home/User_name/.spamassassin]# ls
    ./ ../ auto-whitelist bayes_seen bayes_toks user_prefs
    [/home/User_name/.spamassassin]cat user_prefs
    # SpamAssassin user preferences file. See 'perldoc Mail::SpamAssassin::Conf'
    # for details of what can be tweaked.
    ###########################################################################

    # How many points before a mail is considered spam.
    # required_score 5
    required_score 20

    ~~~~~~~~~~
    there was a required_score manually entered in my user_prefs.
    I removed the value (required_score 20) and it is working fine
     
Loading...

Share This Page