The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SpamAssassin not working and no spam box

Discussion in 'General Discussion' started by ServerGuru, Oct 9, 2004.

  1. ServerGuru

    ServerGuru Member

    Joined:
    Apr 18, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hi Guys,
    I tried everything including bug fixes of new SA 3.0 version. I ran scripts without any success.

    The problem is spamd checking incoming emails and giving message in logs that it was identified spam. Even though spam is identified it's not adding any X headers to email and not moving to "spam" folder. :confused:

    I have disabled and enabled spam box more than 20 times.


    That's all for now.
     
  2. ccccanada

    ccccanada Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    Yes the same problem here!

    Also the user_prefs file was changed in the .spamassasin folder.

    There is also a file there called auto-whitelist.
     
  3. ccccanada

    ccccanada Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
  4. ServerGuru

    ServerGuru Member

    Joined:
    Apr 18, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I tried following things but SA not adding any X-spam headers.
    ====================
    perl -MCPAN -e shell

    cpan> force install Mail::SpamAssassin

    Update your system:

    /scripts/updatenow
    /scripts/exim4
    /scripts/upcp
    =================

    Guess what, i tried "bdraco " instructions and it's working fine now.

    ============================
    If you are still having a problem with spamassasin, please run the following. This will detect/remove old 2.x rules from spamassasin's config


    /scripts/updatenow
    /scripts/fixspamassassinfailedupdate
    /scripts/restartsrv_exim
    ==========

    Thanks a bunch to Mr. Nick :D
     
Loading...

Share This Page