The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spamassassin / spamd not working -- solution

Discussion in 'General Discussion' started by Anishts, Mar 13, 2006.

  1. Anishts

    Anishts Active Member

    Joined:
    Oct 6, 2005
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    HI All,

    1. When restarting exim it will show

    Shutting down spamd: [FAILED] and when starting it will NOT show Starting spamd:

    You may have disabled spamd whm > service manager .

    so whm will create a file /etc/spamdisable

    when you re-eanable spamd through whm > service manager this file may not be deleted.

    so delete /etc/spamdisable and restart exim , spamd will function again.


    2. Given below is the error when restarting exim.

    " Starting spamd: [9128] error: spamd: spamd script is v3.001000, but using modules v3.001001 "


    When cpanel update updates spamassassin the updates (executables) will be installed at

    /usr/share/scripts/ NOT AT working directory /usr/bin and /etc/rc.d/init.d/ .

    solution: :)

    Remove these files from /usr/bin/ and /etc/rc.d/init.d/

    rm -f /usr/bin/spamc
    rm -f /usr/bin/sa-learn
    rm -f /usr/bin/spamassassin
    rm -f /usr/bin/spamd
    rm -f /usr/bin/sa-update
    rm -f /etc/rc.d/init.d/spamassassin

    Now copy the updated files from /usr/share/scripts/

    cp /usr/share/scripts/spamc /usr/bin/
    cp /usr/share/scripts/sa-learn /usr/bin/
    cp /usr/share/scripts/spamassassin /usr/bin/
    cp /usr/share/scripts/spamd /usr/bin/
    cp /usr/share/scripts/sa-update /usr/bin/
    cp /usr/share/scripts/spamassassin /etc/rc.d/init.d/

    Now restart exim. Done :D
     
    #1 Anishts, Mar 13, 2006
    Last edited: Mar 13, 2006
  2. webproject

    webproject Member

    Joined:
    Mar 7, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    it`s work for me!:D
    thanks
     
  3. divya

    divya Registered

    Joined:
    Mar 7, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    The above fix didnt work for me.

    /scripts/fixspamassassinfailedupdate fixed my issue.
     
  4. tomanishkb

    tomanishkb Registered

    Joined:
    Aug 3, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Thanks

    Thanks divya:) .........................
    /scripts/fixspamassassinfailedupdate worked for me thanks a lot.............
     
  5. talos

    talos Member

    Joined:
    May 29, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Hello,


    Come to this thread after a search on spamd failed.

    Alarmed on nobody 48.8 % cpu usage, so pid process killed via ssh.

    After that, exim failed on services. So I try to restart it, stop the service and start it again. Exim started normal but spamd failed to start. So I try to /scripts/restartsrv_spamd but no luck.
    When Exim restarted spamd failed to start.

    Run /scripts/fixspamassassinfailedupdate & fixed my issue :)

    Just wanted to report it for feature referencing.

    Thanks for helping me out on this.

    Regards
    T.L.
     
Loading...

Share This Page