Spamassassin Update Failed, reinstalling!

Bruce

Well-Known Member
Oct 4, 2001
147
0
316
I have been getting this (Spamassassin Update Failed, reinstalling!) for the past 4 days on two of our servers. Is there a way to disable this update ? Not even using Spamass, to many better alternatives.

Thanks
 

Jones

Well-Known Member
Jul 10, 2004
47
0
156
I want to vote upto 5, hehe but I just vote for 1. My first time to vote.

I am still experiencing this problem. I did everything but still re-installing...


Hope they will be able to solve this.
 

Jones

Well-Known Member
Jul 10, 2004
47
0
156
Yup, and I tried this /scripts/fixspamassassinfailedupdate 20 times...


No, that is not the solution...


Until now, spamassassin is still reinstalling again and again...
 

Jones

Well-Known Member
Jul 10, 2004
47
0
156
I think this is happening only to those who disable their spamassassin.

Temporary Solution: Patch By Ben From Cpanel

--- fixspamassassinfailedupdate.orig 2005-01-20 11:25:50.000000000 -0500
+++ fixspamassassinfailedupdate 2005-01-20 11:29:53.000000000 -0500
@@ -7,6 +7,11 @@
use IPC::Open3;
use RestartSrv;

+if ( -e "/etc/spamddisable" || -e "/etc/spamdisable" ) {
+ print "SpamAssassin disabled in Service Manager\n";
+ exit();
+}
+
$sa = '/usr/bin/spamassassin';
if (! -e $sa && -e "/usr/local/bin/spamassassin") {
$sa = '/usr/local/bin/spamassassin';

Caution:

If you run /scripts/updatenow this will wipe the patch again :-(


We need another solution for this.


Jones
 

mr.wonderful

BANNED
Feb 1, 2004
345
1
166
Its happening with Edge too.

Hostname Virtual Host is already setup
PHP version file is up to date
Spamassassin Update Failed, reinstalling!
Testing connection speed...(this could take a while)....Done
Three usable mirrors located
Mirror Check passed for ftp.sedl.org
CPAN: Storable loaded ok
Going to read /home/.cpan/Metadata
Database was generated on Fri, 21 Jan 2005 01:50:12 GMT
Running install for module Mail::SpamAssassin
Running make for F/FE/FELICITY/Mail-SpamAssassin-3.0.2.tar.gz
CPAN: Digest::MD5 loaded ok
CPAN: Compress::Zlib loaded ok
Checksum for /home/.cpan/sources/authors/id/F/FE/FELICITY/Mail-SpamAssassin-3.0.2.tar.gz ok

etc
 

haze

Well-Known Member
Dec 21, 2001
1,550
3
318
mr.wonderful, did you updatenow first ?

Either way, if you apply the above patch and chattr +i ( untill a fix is released in your build ) that should help out for the time being. Works for me.
 

Bruce

Well-Known Member
Oct 4, 2001
147
0
316
(I think this is happening only to those who disable their spamassassin)

Yes, that is correct. If you enable SPAS, the updates stop. If you just disable it in tweak settings it stops but as soon as you disable it in (both) the Server Manager, it starts to update and never stops
 

Vatoloco

Well-Known Member
Jun 21, 2004
99
0
166
Jones said:
I think this is happening only to those who disable their spamassassin.

Temporary Solution: Patch By Ben From Cpanel

--- fixspamassassinfailedupdate.orig 2005-01-20 11:25:50.000000000 -0500
+++ fixspamassassinfailedupdate 2005-01-20 11:29:53.000000000 -0500
@@ -7,6 +7,11 @@
use IPC::Open3;
use RestartSrv;

+if ( -e "/etc/spamddisable" || -e "/etc/spamdisable" ) {
+ print "SpamAssassin disabled in Service Manager\n";
+ exit();
+}
+
$sa = '/usr/bin/spamassassin';
if (! -e $sa && -e "/usr/local/bin/spamassassin") {
$sa = '/usr/local/bin/spamassassin';

Caution:

If you run /scripts/updatenow this will wipe the patch again :-(


We need another solution for this.


Jones
How do we apply that patch?
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,465
30
473
Go on, have a guess
You should be able to get the patched script now with:

/scripts/updatenow

If not, do the following:

1. cd /scripts/

2. create a file called sa.patch and add the patch text mentioned above.

3. patch fixspamassassinfailedupdate sa.patch
 

Vatoloco

Well-Known Member
Jun 21, 2004
99
0
166
Thanks! I noticed they said it was resolved in EDGE builds. I have my update preferences set for RELEASE tree, so I'll just do the patch.

I get this message though when applying the patch:

patch: **** malformed patch at line 4: use IPC::Open3;


One more question, it was mentioned to "apply the above patch and chattr +i". What is chattr +i and how do I do that? Just type chattr +i at the prompt or does that mean I need to do chattr +i /scripts/fixspamassassinfailedupdate ?
 
Last edited:

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,465
30
473
Go on, have a guess
Where'd Bens post go ;)

chattr +i (man chattr) enables the immutable flag on a file. The immutable flag prevents deletion or writing to a file, even by root. The only way to write/delete it is to remove the chattr immutable flag first with chattr -i, e.g.:

chattr +i filename

However, setting the immutable flag on files that cPanel updates is not a good idea as this can break somethings and prevents you getting updates to those files too.
 

KimBO

Well-Known Member
Sep 2, 2004
69
0
156
Hello...

is these bug also at the user prefs for the user own spam definitions... this doesnt work at one from our servers... you can write whatever you want, but it will not be recognised...

Greetings.. KimBO
 

mvhost

Active Member
Sep 23, 2004
25
0
151
My problem with Spamassassin Update Failed

Hi,

I am having this problem with upcp (Spamassassin Update Failed, reinstalling!). And now I naum obtain to apply patch,

I appear the error message: "patch: **** malformed patch at line 4: use IPC::Open3;"

What I must make to correct this?
Already exists some definitive correction for this problem?


Regards,

Fernando Freitas