SpamAssassin whitelist not working

schwim

Well-Known Member
Aug 2, 2006
213
0
166
Hi there everyone!

For some reason, all mail coming from one forum I frequent has begun to get labeled as spam 100% of the time so all notifications are getting dropped in the spam folder. I added the sender's domain to the whitelist:

i.imgur.com/7D4uwnq.png

i.imgur.com/1Vp9lPa.png

In spite of this, all mail sent from this email domain continues to get labeled as spam.

Is there some way I can force mail from this domain to get whitelisted? Am I misunderstanding the process or purpose of the whitelist?

Thanks for your time!
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,250
463
Hello,

Could you let us know the output from /var/log/exim_mainlog for one of the emails in-question after the new entry was added to the SpamAssassin whitelist? EX:

Code:
exigrep MSGID /var/log/exim_mainlog
Replace MSGID with the message ID, as found in the header of an affected message.

Thank you.
 

schwim

Well-Known Member
Aug 2, 2006
213
0
166
Hi there and thanks very much for the help!

Those logs aren't available to me due to lack of root on my VPS account. Is there any other way to find out what's going on or do I need to involve the host to get that data?

{EDIT}

Adding the scores from the bottom of the headers:

Code:
Content analysis details:   (4.3 points, 4.0 required)

  pts rule name              description
 ---- ---------------------- --------------------------------------------------
  6.2 RCVD_IN_MSPIKE_L5      RBL: Very bad reputation (-5)
                            [174.36.49.240 listed in bl.mailspike.net]
  0.0 URIBL_BLOCKED          ADMINISTRATOR NOTICE: The query to URIBL was blocked.
                            See
                            DnsBlocklists - Spamassassin Wiki
                             for more information.
                            [URIs: fullsizebronco.com]
 -0.0 SPF_PASS               SPF: sender matches SPF record
 -1.9 BAYES_00               BODY: Bayes spam probability is 0 to 1%
                            [score: 0.0000]
  0.0 RCVD_IN_MSPIKE_BL      Mailspike blacklisted
X-Spam-Flag: YES
Subject:  ***SPAM***  REDACTED
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,250
463
Hello,

I recommend reaching out to your provider for assistance with this issue so they can take a closer look to see why the whitelist rule isn't functioning.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,250
463
I am having the same problem. I have googled and YouTube everything I can think of but the email still will not come through.
Hello,

Have you reached out to your web hosting provider so they can take a closer look to see what's happening during the message delivery?

Thank you.