The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spamassassin will not disable

Discussion in 'General Discussion' started by Annette, Sep 13, 2003.

Thread Status:
Not open for further replies.
  1. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    We have had several reports of users indicating that SA will not stop tagging thir mail, even though they have disabled SA. We have tested this on various skins, and they're entirely correct: SA is tagging things with "this may be spam" although they do not have SA enabled. We have done the following in an attempt to get this thing to ignore the affected accounts:

    - re-enabled and then disabled SA
    - removed the .spam* items from /home/theiruser
    - changed skins on the affected accounts

    Thus far, nothing has had any affect. We cannot disable SA serverwide, as we do have other users who utilize it, so that is not a viable suggestion. Anyone have any ideas how to turn this thing off for people who really don't want to use it any longer?

    WHM 7.4.2 cPanel 7.4.2-R158

    cPanel.net Support Ticket Number:
     
  2. rvskin

    rvskin Well-Known Member
    PartnerNOC

    Joined:
    Feb 19, 2003
    Messages:
    400
    Likes Received:
    1
    Trophy Points:
    18
    Never happan with us. Something might broke on your server such as spamd, exim.

    I recommend you update exim to the latest version.

    SpamAssassin 2.55 (1.174.2.19-2003-05-19-exp)

    For WHM 7.4.2 cPanel 7.4.2-R158 should be
    exim-4.20-320_cpanel_stmpcontrol_antivirus_rewrite_mailman2

    For WHM 8.0.0 cPanel 8.0.0-E52 should be
    exim-4.22-30_cpanel_stmpcontrol_antivirus_rewrite_mailman2
     
    #2 rvskin, Sep 15, 2003
    Last edited: Sep 15, 2003
  3. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    I imagine if things were broken that badly, we would notice other symptoms rather than just SA not disabling itself. In any case, we are already running the latest versions of everything (nb: exim-4.20-350 is the latest for 7.4.2), since R158 brought those along.

    cPanel.net Support Ticket Number:
     
  4. rvskin

    rvskin Well-Known Member
    PartnerNOC

    Joined:
    Feb 19, 2003
    Messages:
    400
    Likes Received:
    1
    Trophy Points:
    18
    What about 'SpamAssassin 2.55 (1.174.2.19-2003-05-19-exp)'?

    If you could not stop it, you need to increase required hit for that domain to hightest number such as 99. Log in to your Cpanel under Spam Assasin / 'cofigure spam assasin' , but would be my last choice.

    cPanel.net Support Ticket Number:
     
  5. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    As noted, all software is current. Increasing the score is not an acceptable solution, since this affects various clients across multiple servers, and it's ridiculous to continue to have SA interrupt mail delivery for parsing when people don't want it. I'm not looking for suggestions on how to get around the problem - that's trivial to do. I am looking for suggestions as to what the root cause could possibly be in order to get it fixed or for anyone else who may have experienced the same issue so we can compare notes (or, if they fixed theirs, what they did).

    cPanel.net Support Ticket Number:
     
  6. goodmove

    goodmove Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    Yet, in your thread opener you didn't say that, and you clearly asked:

    "Anyone have any ideas how to turn this thing off for people who really don't want to use it any longer?"

    Rvskin was trying to be helpful in that direction and offered a viable and practical solution. All he'd got as a thanks from you is a demeaning reply. :eek:

    > I am looking for suggestions as to what the root cause could possibly be ...

    There isn't a root cause if that's what you're looking for, it's probably your server config.
     
    #6 goodmove, Sep 16, 2003
    Last edited: Sep 16, 2003
  7. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    In my world, a workaround that leaves things tagged by SA != disabling SA (i.e. turning the thing off, like it's supposed to do when someone chooses to disable it). Raising the score does not stop SA from parsing the mail, meaning that SA is not disabled for that account, meaning that my original question remains unanswered.

    A misconfigured server would in fact be a root cause, now, wouldn't it? However, that is not the case here, since this server is identical in all respects to other servers where SA does disable properly - also identical to other servers where SA does not disable properly. If no one has seen this behavior, so be it, but I'm not going to take crap for civilly rejecting nonsolutions or continued suggestions that there is some outdated software at play here when it has been clearly stated that is not the case.


    cPanel.net Support Ticket Number:
     
    #7 Annette, Sep 16, 2003
    Last edited: Sep 16, 2003
  8. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    There were a few problem with spamassasin that have been worked around in the 8.x releases.

    cPanel.net Support Ticket Number:
     
Loading...
Thread Status:
Not open for further replies.

Share This Page