esmith

Member
Oct 16, 2001
22
0
301
Mail is delivered when mail is sent to cpanel box but a message is returned to the sender stating...

Failed to run A_FROM_IN_AUTO_WLIST SpamAssassin test, skipping:

(Cannot get host name of local machine at /usr/lib/perl5/site_perl/5.005/Mail/SpamAssassin/DBBasedAddrList.pm line 34

)

Ideas?

Ed

PowerSurge
 

esmith

Member
Oct 16, 2001
22
0
301
hostname = zeus.domain.com

hostname = zeus.domain.com

Which should be correct for this server.

thanks!
Ed
 

Wallaby

Well-Known Member
Aug 15, 2001
131
1
318
I get a similar thing: some (but not all) mail sent to an account with Spam Assasin enabled generates a &Mail delivery failed: returning message to sender& message (even though the message is actually delivered ok).

The error message I get is as follows:

Failed to run A_FROM_IN_AUTO_WLIST SpamAssassin test, skipping:
(Cannot open auto_whitelist_path /home/&account directory&/.spamassassin/auto-whitelist: No such file or directory
)

(I took out the real text where &account directory& is shown above)

My hostname is correct. The file /home/&account directory&/.spamassassin/auto-whitelist does exist ok.

Ideas?
 
B

bdraco

Guest
[quote:a09388122c][i:a09388122c]Originally posted by Wallaby[/i:a09388122c]

I get a similar thing: some (but not all) mail sent to an account with Spam Assasin enabled generates a &Mail delivery failed: returning message to sender& message (even though the message is actually delivered ok).

The error message I get is as follows:

Failed to run A_FROM_IN_AUTO_WLIST SpamAssassin test, skipping:
(Cannot open auto_whitelist_path /home/&account directory&/.spamassassin/auto-whitelist: No such file or directory
)

(I took out the real text where &account directory& is shown above)

My hostname is correct. The file /home/&account directory&/.spamassassin/auto-whitelist does exist ok.

Ideas?
[/quote:a09388122c]

Make sure the user owns .spamassassin
You might want chmod -R it..
 

Wallaby

Well-Known Member
Aug 15, 2001
131
1
318
The .spamassassin directory has the user as owner and group.

The auto-whitelist file inside this dir has as owner the user and as group &mail&. Permissions are read and write to owner only (-rw------).

Is this correct?
 

Wallaby

Well-Known Member
Aug 15, 2001
131
1
318
Any response on this?

Another thing: there seems to be something seriously cooky with SpamAssasin. I have it one one test domain for... errr.... testing. When I send it some known spam to see what happens, I get negative hits on the tests. Like:

X-Spam-Status: No, hits=-95.3 required=5.0 tests=PLING_PLING,PLING,EXCUSE_17,CLICK_BELOW,DEAR_SOMEBODY,MAILTO_WITH_SUBJ,MAILTO_WITH_SUBJ_REMOVE,A_FROM_IN_AUTO_WLIST version=2.01

If it's this seriously broken can we please just have it removed from CPanel?
 

esmith

Member
Oct 16, 2001
22
0
301
theme change

change your theme removing the the ability to turn on spamassassin and then just remove the .spamassassin files for the domains that have been brave and turned it on.
 

Wallaby

Well-Known Member
Aug 15, 2001
131
1
318
Yes, sure, but the point is that if the software is so buggy it should not be in CPanel at all. It should not be necessary for hosts to faff around with custom themes.

Harrumph;)

It worked fine when we were on RedHat 6.2, but now we're using RedHat 7.2 it is a real mess.

Nick: please? Pretty please? At least include it in the list of &switch-off-able& services in WHM so we can prevent customers screwing their email up.
 

bert

Well-Known Member
Aug 21, 2001
602
0
316
Any ideas on how to fix this yet?
 

First Faze

Well-Known Member
Jan 30, 2002
47
0
306
I'm getting the same exact problem.