The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SpamAssassin X-Spam headers are blank

Discussion in 'E-mail Discussions' started by SpeechUtilities, Nov 3, 2014.

  1. SpeechUtilities

    SpeechUtilities Registered

    Joined:
    Oct 16, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    I am writing to see if I understand how the SpamAssassin X-Spam headers work in conjunction with the SpamAssassin configuration options in cPanel.

    ALL of the email headers I get in my domain look like:

    X-Spam-Status: No, score=
    X-Spam-Score:
    X-Spam-Bar:
    X-Ham-Report:
    X-Spam-Flag: NO

    I found a message on this forum:


    that seemed to point to a solution, but after bugging my web hosting company support people, they replied that it is really running by showing me:
    root@mccoy [~]# /scripts/restartsrv_spamd --status
    spamd (/usr/local/cpanel/3rdparty/perl/514/bin/spamd -d --allowed-ips=50.116.56.249 --pidfile=/var/run/spamd.pid --max-children=1 --max-spare=1) running as root with PID 3081 (pidfile check method)

    What I want to know is with the blank X-Spam headers, will SpamAssassin Auto Delete (or Enable Spam Box) EVER work because it seems to me that a Spam Score is required because Auto Delete generates an Account Level Filter called Generated SpamAssassin Discard Rule, and everything seems to depend on a spam score of which I have never seen any. I can change the rule from 'Discard message' to 'Deliver to a folder', and nothing ever happens. I continue to get the same amount of spam in either case, and nothing shows in the folder.

    I have also tried to enable SpamAssassin Spam Box, and configured Squirrel mail to 'subscribe' to the Junk and spam folders, and nothing ever shows up in either one.

    As far as I know, I do not have access to WHM mentioned in the thread above.

    cPanel SpamAssassin says that SpamAssassin is 'enabled' but I don't see anywhere to turn it off OR on.

    Can anyone enlighten me to this spam score business? I should be seeing Spam score numbers in my
    X-Spam headers. Right?

    Thanks for your consideration
     
  2. SpeechUtilities

    SpeechUtilities Registered

    Joined:
    Oct 16, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please ensure you attempt to send an actual SPAM message to an email address hosted on your server to test if this option is functioning as expected. You can find a test SPAM message at:

    http://spamassassin.apache.org/gtube/gtube.txt

    This will allow you to test SpamAssassin with a message that is detected as SPAM.

    Thank you.
     
  4. SpeechUtilities

    SpeechUtilities Registered

    Joined:
    Oct 16, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Well, I had tried the GTUBE a few days ago, but I tried again just now. The result is the same. Received the message (from outside my domain) with blank X-Spam headers (attached - edited real addresses out). If SpamAssassin is functioning correctly, shouldn't EVERY message (spam or not) have a score? NONE of mine do.

    If there are no scores, it would explain why the Auto-Delete filter never works, and why my web host support people changing of SpamAssassin score from default (5) to 4, then to 3 don't really make any difference in the amount of spam I get?

    Thanks for your insights
     

    Attached Files:

  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Right, you should provide the output of the Gtube test message headers to your web hosting provider so they can take a closer look. It's not something you will be able to resolve without root access to the server.

    Thank you.
     
  6. SpeechUtilities

    SpeechUtilities Registered

    Joined:
    Oct 16, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Thanks very much for confirming how things (don't) work.

    I know you may not be able to tell much more without access to things, but is there anything you could steer my host support people to, or in the direction of, because, frankly I think that they are unable to figure this problem out. I have already been sending them the blank headers, unless you think the Gtube example itself reveals something I'm not aware of?

    Is there any chance it could have something to do with the fact that my domain registrar is not them, but external to them? Just grasping at straws here.

    Thanks again for your inputs.
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    It's not related to your domain registrar. You could have them open a support ticket with us if they are unable to determine why SpamAssassin is not functioning as expected.

    Thank you.
     
Loading...

Share This Page