The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

spamd always failing

Discussion in 'General Discussion' started by Zion Ahead, Feb 21, 2007.

  1. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Spamd is always failing and I tried various methods mentioned in the forums including uninstall / reinstall via whm.



    Also:

    /scripts/perlinstaller Digest::SHA1
    /scripts/perlinstaller --force Mail::SpamAssassin
    /etc/rc.d/init.d/exim restart
    /scripts/restartsrv spamd


    Now, I got this error during the above process:

    Code:
    root@server [~]# /etc/rc.d/init.d/exim restart
    Shutting down clamd:                                       [  OK  ]
    Shutting down exim:                                        [  OK  ]
    Shutting down antirelayd:                                  [  OK  ]
    Shutting down spamd:                                       [  OK  ]
    Starting clamd:                                            [  OK  ]
    Starting exim:                                             [  OK  ]
    Starting exim-smtps:                                       [  OK  ]
    Starting antirelayd:                                       [  OK  ]
    Starting spamd: [25517] error: spamd: could not create INET socket on 127.0.0.1:783: Address already in use
    spamd: could not create INET socket on 127.0.0.1:783: Address already in use
                                                               [FAILED]
    I've done forced cpanel upgrade as well. Any suggestions?
     
  2. fuzzie

    fuzzie Well-Known Member

    Joined:
    Oct 12, 2002
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    I have the same problem.
    Tried /scripts/restartsrv_clamd

    got:

    clamd: no process killed
    clamd: no process killed
    ERROR: Parse error at line 76: Option FixStaleSocket requires boolean argument.
    ERROR: Can't open/parse the config file /etc/clamd.conf
     
  3. omenix

    omenix Active Member

    Joined:
    Aug 24, 2005
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    /dev/null
    Try to update your clamav to latest version from cpanel update version 0.90 if I'm not mistaken and use socket instead of listening to tcp port.. and also increase your maxchild per connection if your server has big activity on email connection.. you can search on this forum how to do it..

    keyword: spamd socket
     
  4. hbouma

    hbouma Well-Known Member

    Joined:
    Jun 8, 2002
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    The problem is...

    I don't know if this is a different problem than the one listed at the start of the ticket, but its because cPanel updated the clamav connector with the new version of clamav 0.90. However, they didn't have their addon update the config file to work with the new version. As a result, clamd won't start for anyone who has been updated to clamav 0.90.

    So you need to either fix /etc/clamd.conf or wait for cPanel to hopefully come out with a fix for the problem. Until its resolved, exim won't accept emails for delivery.

    Hal
     
    #4 hbouma, Feb 22, 2007
    Last edited: Feb 22, 2007
  5. fuzzie

    fuzzie Well-Known Member

    Joined:
    Oct 12, 2002
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    "So you need to either fix /etc/clamd.conf or wait for cPanel to hopefully come out with a fix for the problem. Until its resolved, exim won't accept emails for delivery."

    What do I need to do to clamd.conf to make it work?

    Found this too:
    http://forums.cpanel.net/showthread.php?t=63843&highlight=clamd
    Tried that fix, but still failing.

    FIXED; forced update and /usr/local/cpanel/whostmgr/bin/whostmgr2 --updateaddons fixed it.
    thanks!
     
    #5 fuzzie, Feb 22, 2007
    Last edited: Feb 22, 2007
  6. viooltje

    viooltje Well-Known Member

    Joined:
    Mar 14, 2004
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    thanks allot man it worked for me and I hope this will stay so!

    http://forums.cpanel.net/showthread.php?t=63843&page=3

    /scripts/perlinstaller Digest::SHA1
    /scripts/perlinstaller --force Mail::SpamAssassin
    /etc/rc.d/init.d/exim restart
    /scripts/restartsrv spamd


    root@system [~]# /etc/rc.d/init.d/exim restart
    Shutting down exim: [ OK ]
    Shutting down antirelayd: [ OK ]
    Shutting down spamd: [FAILED]
    Starting exim: [ OK ]
    Starting exim-smtps: [ OK ]
    Starting antirelayd: [ OK ]
    Starting spamd: [ OK ]
    root@system [~]# /scripts/restartsrv spamd
    Waiting for spamd to restart..............finished.

    root 13717 7.2 1.1 29804 24192 ? Ss 05:20 0:00 /usr/bin/spamd -d --allowed-ips=127.0.0.1 --pidfile=/var/run/spamd.pid --max-children=5
    root 13718 0.0 1.0 29804 22676 ? S 05:20 0:00 spamd child
    root 13719 0.0 1.0 29804 22556 ? S 05:20 0:00 spamd child

    spamd started ok
    root@system [~]#


    root@system [~]# /etc/rc.d/init.d/exim restart
    Shutting down exim: [ OK ]
    Shutting down antirelayd: [ OK ]
    Shutting down spamd: [ OK ]
    Starting exim: [ OK ]
    Starting exim-smtps: [ OK ]
    Starting antirelayd: [ OK ]
    Starting spamd: [ OK ]
    root@system [~]# /etc/rc.d/init.d/exim restart

    Shutting down exim: [ OK ]
    Shutting down antirelayd: [ OK ]
    Shutting down spamd: [ OK ]
    Starting exim: [ OK ]
    Starting exim-smtps: [ OK ]
    Starting antirelayd: [ OK ]
    Starting spamd: [ OK ]
    root@system [~]#
     
Loading...

Share This Page