The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

spamd causing errors !!

Discussion in 'General Discussion' started by mitul, May 5, 2006.

  1. mitul

    mitul Well-Known Member

    Joined:
    Feb 8, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    Recently spamd is causing tremndous load on server.

    - CPU load gove above 10.00
    - BSMTP pipe timeout error occours if server load is high.

    Any idea how do I control load genrated because of spamd??

    Thank you,
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Not a lot you can do. spamd is a CPU and memory hog. The only thing you can realistically do is to reduce the email traffic by ensuring that no domains are using :blackhole: or /dev/null in /etc/valiases and are using :fail: instead. Also, make sure any Default Addresses that don't need to be set are also set to :fail:

    You could also consider inline RBL checking ACLs in the exim configuration.

    You could also control the email load somewhat by offloading to the exim queue if the load average rises too high:

    queue_only_load = 4
     
  3. ivankovalenko

    ivankovalenko Active Member

    Joined:
    Jul 19, 2005
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    as i think of it, if you have a spare server around, you can dedicate it to spamd proccessing and connect exim to it directly by ip, not socket like its done in the exim now
     
  4. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    There is alot you can do. You can completely stop spamd by disabling it in System Services.
     
  5. mitul

    mitul Well-Known Member

    Joined:
    Feb 8, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Thank you for your suggestion and responses. I will try them.
     
  6. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    I would get rid of spamd and completely disable it. We did it on every server including our new freebsd boxes. What a waste of cpu resources. If you are doing spam filtering at the server level is absolutely no reason to do it at the user level.
     
  7. mitul

    mitul Well-Known Member

    Joined:
    Feb 8, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    I manage to control the server load by implementing the RBL list in exim.conf

    From last 2 days server load seems to be quite stable.

    Regards,
     
Loading...

Share This Page