salvatore333

Well-Known Member
Mar 27, 2003
229
0
166
WHM 11.26.20
CENTOS 5.5 x86_64 xen pv on ns5


i keep getting the below emails. about 10 a day and by the time i login to check it, its running again. i tried every resolution i could find online. any other ideas?
======================================
spamd failed @ Thu Oct 28 02:38:09 2010. A restart was attempted automagically.
Service Check Method: [check command]

Cmd Service Check Raw Output: Spamd is not running

======================================

things i tried below and did not work.

increased max children from 3 to 20.
----------------------------------------
/scripts/fixspamassassinfailedupdate
------------------------------------------
/scripts/perlinstaller Digest::SHA1
/scripts/perlinstaller --force Mail::SpamAssassin
/etc/rc.d/init.d/exim restart
/scripts/restartsrv spamd
-----------------------------------------
/scripts/upcp --force
/scripts/restartsrv_spamd --status
/scripts/restartsrv_spamd
-----------------------------------------


thanks very much for any advice.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
I'd suggest unchecking monitor to allow it to fail, then opening a ticket for us to see it in a failed state to see what's going on. You can open a ticket using the link in my signature or via WHM > Support Center > Contact cPanel

Also, have you checked /var/log/maillog when it's failed to see if there's anything there in regards to the failure? When spamd shuts down, it should log something to /var/log/maillog