Smokovsky

Registered
Sep 29, 2022
3
0
1
Poland
cPanel Access Level
Root Administrator
Hi! I just got brand new VPS (CentOS 7) on which spamd service was seem to be faulty from the very beggining.
I'm getting emails from cPanel Monitoring every few minutes saying "FAILED ⛔ : spamd <ip>". I saw some simmilar posts on the forum so I've tried to make cPanel update from WHM, but it didn't help. Tried this way /scripts/upcp --force but spamd keeps being down.

This is what I get when trying to start it (/scripts/restartsrv_spamd )


[[email protected] /]# /scripts/restartsrv_spamd
Waiting for “spamd” to start ……info [restartsrv_spamd] systemd failed to start the service “spamd” (The “/usr/bin/systemctl restart spamd.service --no-ask-password” command (process 12992) reported error number 1 when it ended.): Job for spamd.service failed. See "systemctl status spamd.service" and "journalctl -xe" for details.

…Waiting for spamd,spamd -d to shutdown ... not running.
info [restartsrv_spamd] The service 'spamd' failed to restart. Trying '/usr/local/cpanel/3rdparty/perl/532/bin/spamd'.
info [restartsrv_spamd] systemd failed to start the service “spamd” (The “/usr/bin/systemctl restart spamd.service --no-ask-password” command (process 13007) reported error number 1 when it ended.): Job for spamd.service failed. See "systemctl status spamd.service" and "journalctl -xe" for details.

…failed.

Cpanel::Exception::Services::StartError
Service Status
undefined status from Cpanel::ServiceManager::Services::Spamd

Service Error
(XID beb3ba) The “spamd” service failed to start.

Startup Log
Sep 29 23:48:04 vps-xxxxxxxxx.vps.ovh.net systemd[1]: Starting Apache SpamAssassin™ deferral daemon...
Sep 29 23:48:06 vps-xxxxxxxxx.vps.ovh.net spamd[13014]: Timeout::_run: check: no loaded plugin implements 'check_main': cannot scan!
Sep 29 23:48:06 vps-xxxxxxxxx.vps.ovh.net spamd[13014]: Check that the necessary '.pre' files are in the config directory.
Sep 29 23:48:06 vps-xxxxxxxxx.vps.ovh.net spamd[13014]: At a minimum, v320.pre loads the Check plugin which is required.
Sep 29 23:48:14 vps-xxxxxxxxx.vps.ovh.net systemd[1]: Can't open PID file /run/spamd.pid (yet?) after start: No such file or directory
Sep 29 23:48:14 vps-xxxxxxxxx.vps.ovh.net systemd[1]: Failed to start Apache SpamAssassin™ deferral daemon.
Sep 29 23:48:14 vps-xxxxxxxxx.vps.ovh.net systemd[1]: Unit spamd.service entered failed state.
Sep 29 23:48:14 vps-xxxxxxxxx.vps.ovh.net systemd[1]: spamd.service failed.

spamd has failed. Contact your system administrator if the service does not automagically recover.



Any idea how to make this spamd work?



@EDIT:
If it's any help, I've found this errors looped in var/log/maillog:

Sep 30 04:35:06 vps-xxxxxxxxx spamc[4670]: connect to spamd on ::1 failed, retrying (#1 of 3): Connection refused
Sep 30 04:35:06 vps-xxxxxxxxx spamc[4670]: connect to spamd on 127.0.0.1 failed, retrying (#1 of 3): Connection refused
Sep 30 04:35:07 vps-xxxxxxxxx spamc[4670]: connect to spamd on ::1 failed, retrying (#2 of 3): Connection refused
Sep 30 04:35:07 vps-xxxxxxxxx spamc[4670]: connect to spamd on 127.0.0.1 failed, retrying (#2 of 3): Connection refused
Sep 30 04:35:08 vps-xxxxxxxxx spamc[4670]: connect to spamd on ::1 failed, retrying (#3 of 3): Connection refused
Sep 30 04:35:08 vps-xxxxxxxxx spamc[4670]: connect to spamd on 127.0.0.1 failed, retrying (#3 of 3): Connection refused
Sep 30 04:35:08 vps-xxxxxxxxx spamc[4670]: connection attempt to spamd aborted after 3 retries
Sep 30 04:35:11 vps-xxxxxxxxx spamd[4735]: Timeout::_run: check: no loaded plugin implements 'check_main': cannot scan!
Sep 30 04:35:11 vps-xxxxxxxxx spamd[4735]: Check that the necessary '.pre' files are in the config directory.
Sep 30 04:35:11 vps-xxxxxxxxx spamd[4735]: At a minimum, v320.pre loads the Check plugin which is required.
Sep 30 04:35:19 vps-xxxxxxxxx dovecot: pop3-login: Disconnected: Aborted login by logging out (no auth attempts in 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, secured, session=<xxxxxxxxx /AAAB>
Sep 30 04:35:19 vps-xxxxxxxxx dovecot: lmtp(4777): Connect from local
Sep 30 04:35:19 vps-xxxxxxxxx dovecot: lmtp(4777): Disconnect from local: Logged out (state=GREETING)
Sep 30 04:35:19 vps-xxxxxxxxx dovecot: imap-login: Login: user=<__cpanel__service__auth__imap__gizv3entm1vlew1y>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=4786, secured, session=<xxxxxxxxx /AAAB>
Sep 30 04:35:19 vps-xxxxxxxxx dovecot: imap(__cpanel__service__auth__imap__gizv3entm1vlew1y)<4786><BZN5hd3pltZ/AAAB>: Disconnected: Logged out in=11, out=519, bytes=11/519
 
Last edited:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
13,382
2,107
363
cPanel Access Level
Root Administrator
Hey there! Have you tried a forced update with "/scripts/upcp --force" to see if that gets things working? That will often resolve many odd issues.

If that doesn't work, I'd try disabling and reenabling the tool as outlined here: https://support.cpanel.net/hc/en-us...off-Spamassassin-aka-spamd-on-a-cPanel-server

If that still doesn't get things to run well, it might be time to submit a ticket to our team so we can take a look at the system.