The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

spamd keeps failing

Discussion in 'General Discussion' started by lelahosting, Mar 28, 2012.

  1. lelahosting

    lelahosting Member

    Joined:
    Aug 17, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    I have had this occur twice now(about a week apart) and I am not sure on what to do on this one.

    I restart exim and spamd is fine again.

    Here is the error it gives when it fails.

    spamd failed @ Wed Mar 28 07:33:33 2012. A restart was attempted automagically.

    Service Check Method: [check command]

    Number of Restart Attempts: 1

    Cmd Service Check Raw Output: Spamd is not running Raw Output:


    Startup Log: Mar 27 03:12:14.096 [29367] warn: server socket setup failed, retry 1: spamd: could not create INET socket on 127.0.0.1:783: Address already in use Mar 27 03:12:17.780 [29367] warn: Argument "" isn't numeric in addition (+) at /usr/lib/perl5/site_perl/5.8.8/Mail/SpamAssassin/NetSet.pm line 122.
    Mar 27 03:12:17.870 [29367] warn: oops! unparseable IPv6 address for 127/8: 428192288 at /usr/lib/perl5/site_perl/5.8.8/Mail/SpamAssassin/NetSet.pm line 128.
    Mar 27 03:12:18.026 [29367] warn: oops! unparseable IPv6 address for 127/8: 428192640 at /usr/lib/perl5/site_perl/5.8.8/Mail/SpamAssassin/NetSet.pm line 128.

    Any ideas on this one?
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Next time this occurs, rather than restarting it immediately, could you run the following command?

    Code:
    netstat -lpn | grep 783
     
  3. lelahosting

    lelahosting Member

    Joined:
    Aug 17, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    It just did it again now. I ran the command and it didn't return anything.

    root@bat [~]# netstat -lpn | grep 783
    root@bat [~]#

    I restarted the mail server again and it was fine after that.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please submit a ticket. If the response in the logs is "spamd: could not create INET socket on 127.0.0.1:783: Address already in use" then something should have been listening on that port (783). Wait to submit the ticket when this occurs, then please do not restart the service but allow us to troubleshoot the issue. You can submit a ticket using WHM > Support Center > Contact cPanel or using the link in my signature. Thanks!
     
Loading...

Share This Page