The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spamd keeps failing

Discussion in 'General Discussion' started by Brook, May 29, 2007.

  1. Brook

    Brook Well-Known Member

    Joined:
    Apr 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    Any ideas why spamd keeps on failing? Should I just stop using it? (If so how do I turn it off?)

    It's been gradually getting worse, started getting the emails a few months ago but recently it's built up into getting a few of these emails an hour :eek:

    Any help appreciated.
     
  2. bashcpanel

    bashcpanel Well-Known Member

    Joined:
    Apr 15, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Try /scripts/fixspamassassinfailedupdate and see how it goes there .

    Thanks,
     
  3. Brook

    Brook Well-Known Member

    Joined:
    Apr 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    Hi

    Tried that - it ended with:

    And I'm still getting the emails :(

    Any other ideas?
     
  4. bashcpanel

    bashcpanel Well-Known Member

    Joined:
    Apr 15, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
  5. Brook

    Brook Well-Known Member

    Joined:
    Apr 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    Thanks - I've tried that, will let you know how it goes. Do you know how I can deactivate Spam Assasin if I need to? I don't think anyone uses it on my server anyway. I tried it a while back and it hardly stopped any spam :-/
     
  6. Brook

    Brook Well-Known Member

    Joined:
    Apr 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    Nope... still getting them :(

    I've disabled it for now as it adds a lot of load in the day time (Main >> Server Configuration >> Tweak Settings >> then unchecked and saved). Will see if there's any more help and will try it again in the evening.

    Any other ideas? I updated perl and the kernal last night.
     
  7. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
  8. Brook

    Brook Well-Known Member

    Joined:
    Apr 22, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    Hi Andy

    I searched the forums too - although looks like you got better results (shame google can;t index the pages, I usually use it to search specific forums).

    I'm gonna try this now:

    I already upgraded perl to 5.8.8.

    Will keep updating the thread. Cheers for your help.
     
  9. cmashraf

    cmashraf Guest

    solution

    Hiya Guys,

    Fixed this issue by upgrading the Mail-SpamAssassin to the latest version. Try the following steps ,

    wget http://mirror.uta.edu/CPAN/authors/id/F/FE/FELICITY/Mail-SpamAssassin-3.0.4.tar.gz
    tar -xzvf Mail-SpamAssassin-3.0.4.tar.gz
    cd Mail-SpamAssassin-3.0.4
    perl Makefile.PL PREFIX=$HOME
    make
    make install
    chattr -ia /usr/
    chattr -ia /usr/bin
    mv spamd/spamd /usr/bin/
    mv spamc/spamc /usr/bin/
    /etc/rc.d/init.d/exim restart
    /scripts/restartsrv spamd

    Hope this will work for you guys also : -)
     
  10. nilesh_kolte

    nilesh_kolte Well-Known Member

    Joined:
    Apr 13, 2006
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Pune ,India
    cPanel Access Level:
    Root Administrator
    First uninstall Spamassassin.

    WHM > Service Manager > spamd
    WHM > Tweak Settings > SpamAssassin

    Then disable it in the Feature Manager > Edit disabled and untick it.
    Then you need to remove it from any accounts that have it enabled in your /home partition(s):

    find /home/ -name .spamassassinenable -maxdepth 2 | xargs rm -fv

    Install Spamassassin using the following steps.

    WHM > Service Manager > spamd
    WHM > Tweak Settings > SpamAssassin
    Then Enable it in the Feature Manager > Edit Enable and tick it.

    perl -MCPAN -e 'install Digest::SHA1;'
    perl -MCPAN -e 'install Mail::SpamAssassin;'
    perl -MCPAN -e 'install Mail::SpamAssassin::NoMailAudit;'
    rm -Rf /home/.cpan
    rm -Rf /root/.cpan
    rm -Rf /root/.cpcpan
    /scripts/updatenow
    /scripts/perlinstaller
    /scripts/perlinstaller --force HTML::Tagset
    /scripts/fixspamassassinfailedupdate
    /etc/rc.d/init.d/exim restart
    /scripts/restartsrv spamd

    This will fix the issue
     
  11. RKF

    RKF Member

    Joined:
    Jul 25, 2003
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Spam Assassin broke on my box after upgrading to V11. This fixed it. Many thanks.
     
Loading...

Share This Page