The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

spamd processes stuck causing high load

Discussion in 'E-mail Discussions' started by stormy, Jan 21, 2016.

  1. stormy

    stormy Well-Known Member

    Joined:
    Nov 22, 2003
    Messages:
    108
    Likes Received:
    6
    Trophy Points:
    18
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    We are seeing this for the last 2-3 days on two different servers. Multiple spamd processeses by a user that has little or no incoming mail, taking up 100% of CPU usage in top.

    No matter what we try, the processes reappear. We have tried deleting the bayes databases for the user, restarting exim several times, suspending and unsuspending the account, killing the processes, nothing works.

    Any ideas?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. stormy

    stormy Well-Known Member

    Joined:
    Nov 22, 2003
    Messages:
    108
    Likes Received:
    6
    Trophy Points:
    18
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    I'm familiar with that thread. I was suffering the "spamd failed" problem a few weeks back. I did disable the KAM rules just in case. cPanel support determined it was not related, and added maxspare=7 to /etc/cpspamd.conf in order to deal with this. This increased load a bit too much so I lowered it to maxspare=4.

    That was a few weeks back, and everything was normal until a couple days.

    However, the server that is most affected by this problem today wasn't affected by this other problem, and has no custom spamd configuration.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Please verify the version of cPanel installed on your system, and if any of the following options are enabled in "WHM >> Exim Configuration Manager >> Basic Editor":

    Enable BAYES_POISON_DEFENSE Apache SpamAssassin™ ruleset
    Enable KAM Apache SpamAssassin™ ruleset
    Enable the Apache SpamAssassin™ ruleset that cPanel uses on cpanel.net


    Thank you.
     
  5. stormy

    stormy Well-Known Member

    Joined:
    Nov 22, 2003
    Messages:
    108
    Likes Received:
    6
    Trophy Points:
    18
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    I'm on WHM 11.52.2 (build 4).

    • BAYES_POISON_DEFENSE is on
    • KAM is off
    • SpamAssassin™ ruleset that cPanel is on
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  7. stormy

    stormy Well-Known Member

    Joined:
    Nov 22, 2003
    Messages:
    108
    Likes Received:
    6
    Trophy Points:
    18
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    I disabled all three and haven't seen the issue reoccur today. cPanel support had also advised to add this to the spamd configuration, though it didn't solve the issue:
    maxchildren=10
    timeoutchild=120
    timeouttcp=60
     
Loading...

Share This Page