Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Spamd service wont start

Discussion in 'E-mail Discussion' started by Patricio dos Santos, Jun 23, 2017.

Tags:
  1. Patricio dos Santos

    Joined:
    Jun 22, 2017
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Luanda
    cPanel Access Level:
    Root Administrator
    Checking WHM Service Status, I can see that "spamd" service is not running.

    Trying to run this command:

    Gives me the following error:

    Code:
    Waiting for “spamd” to start ……warn [restartsrv_spamd] The 'spamd' service's PID file '/var/run/spamd.pid' did not appear after 10 seconds.
    
    …info [restartsrv_spamd] The service 'spamd' failed to restart. Trying '/usr/local/cpanel/3rdparty/perl/524/bin/spamd'.
    …failed.
    
    Cpanel::Exception::Services::StartError
    Service Error
            (XID 4mrv5z) The “spamd” service failed to start.
    
    Startup Log
            child process [3612] exited or timed out without signaling production of a PID file: exit 255 at /usr/local/cpanel/3rdparty/perl/524/bin/spamd line 3093.
    
    Log Messages
            Jun 23 16:42:44 arcturus spamd[3609]: child process [3612] exited or timed out without signaling production of a PID file: exit 255 at /usr/local/cpanel/3rdparty/perl/524/bin/spamd line 3093.
            Jun 23 16:42:43 arcturus spamd[3612]: spamd: cannot create /tmp/spamd-3612-init: Too many links at /usr/local/cpanel/3rdparty/perl/524/bin/spamd line 3152.
            Jun 23 16:42:43 arcturus spamd[3609]: logger: removing stderr method
    
    
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,793
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you try moving those symbolic links out of the way and then restart SpamAssassin to see if that helps? EX:

    Code:
    mkdir /root/old-spamd-links
    cd /tmp
    mv -v spamd-* /root/old-spamd-links/
    /scripts/restartsrv_spamd
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Patricio dos Santos

    Joined:
    Jun 22, 2017
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Luanda
    cPanel Access Level:
    Root Administrator
    The command:

    gives me this error:
    spamd is not the only service down. mailman service failed to start to. Trying to start it manually, gives me the following:

    Tomcat down after kernel update
    I think the problem is caused by the same reason explained here:
     
    #3 Patricio dos Santos, Jun 23, 2017
    Last edited: Jun 23, 2017
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,793
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look?

    Thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Patricio dos Santos

    Joined:
    Jun 22, 2017
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Luanda
    cPanel Access Level:
    Root Administrator
    Done!

    My Support Request ID is: 8640521
     
  6. Patricio dos Santos

    Joined:
    Jun 22, 2017
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Luanda
    cPanel Access Level:
    Root Administrator
    I had problems with Tomcat as described here: Tomcat down after kernel update which I believe generates a lot of error logs.

    As I know, there's a limit of about 32,000 links per inode, for this reason, spamd was not able to create PID file.

    I moved to another folder all error logs, now all services are working perfectly.

    Thanks
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,793
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I'm glad to see the issue was addressed. Thank you for updating us with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice