The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spamd unable to restart after update.

Discussion in 'General Discussion' started by ambition13, Nov 11, 2010.

  1. ambition13

    ambition13 Active Member

    Joined:
    Jan 24, 2006
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    After last night's update, I got an email from my server with topic:

    Cron <root@server> sa-update && /etc/init.d/spamd restart

    And the content of the message says:

    /bin/sh: /etc/init.d/spamd: No such file or directory

    I checked the /etc/init.d directory and indeed spamd is not there. Never had this message before on this server which has been running for years. Any way to fix this?
     
    #1 ambition13, Nov 11, 2010
    Last edited: Nov 11, 2010
  2. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    try running a cpanel update again to see if it fixes the problem
     
  3. ambition13

    ambition13 Active Member

    Joined:
    Jan 24, 2006
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Ran /scripts/upcp and the problem still exists.

    If I do "spamd -V" from shell I get:

    Code:
    SpamAssassin Server version 3.3.1
      running on Perl 5.8.8
    Nov 11 18:51:50.596 [1758] error: Can't locate Socket6.pm in @INC (@INC contains: /usr/local/cpanel/spamassassin_sandbox /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.6.2 /usr/lib/perl5/site_perl) at /usr/lib/perl5/site_perl/5.8.8/IO/Socket/SSL.pm line 73.
      with SSL support (IO::Socket::SSL 1.34)
      with zlib support (Compress::Zlib 2.03)
    
    Not sure if that is related or not.

    Any other ideas?
     
    #3 ambition13, Nov 11, 2010
    Last edited: Nov 11, 2010
  4. ambition13

    ambition13 Active Member

    Joined:
    Jan 24, 2006
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Ok, I was able to resolve the spamd -V problem by installing the Socket6 and INET6 perl modules from within WHM. Ran /scripts/upcp again and still no spamd file in /etc/init.d.

    So back to the drawing board.
     
  5. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    I have seen this happen when you have two versions of SpamAssassin installed (usually 3.2.x and 3.3.x). Do you by chance have a spamassassin rpm installed?

    If so you can remove it and reinstall the correct version with the following:

    Code:
    rpm -e spamassassin
    /scripts/perlmods -u Mail::SpamAssassin
    /scripts/installspam
    
    If that doesn't solve the problem, I would recommend opening a ticket.
     
Loading...

Share This Page