The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spamd won't start after update.

Discussion in 'General Discussion' started by jpabboud, Aug 22, 2005.

  1. jpabboud

    jpabboud Member

    Joined:
    Jun 10, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I updated Cpanel to CPanel 10.6.0-R55 tonight and spamd won't start.

    I tried a lot of things that I found searching the forum but I always get the CPAN error.

    oot@SERVER1 [/scripts]# /scripts/fixspamassassinfailedupdate
    Spamassassin Update Failed, reinstalling!
    Method: Perl Expect
    Unable to locate working spamc! Please check your installation.
    Unable to locate working spamd! Please check your installation.
    Unable to locate working spamassassin! Please check your installation.
    Testing connection speed...(this could take a while)....Done
    Ran out of working CPAN mirrors. Please contact cPanel Support at cPanelPerl.pm line 218.
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider

    rm -rf /root/.cpcpan
     
  3. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    cpan.org has been broken all day.. the brokeness even got propgated to all the cpan mirrors.

    Its finally fixed though. So you aren't the first person to have to run that command today :(
     
  4. jpabboud

    jpabboud Member

    Joined:
    Jun 10, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    That fixed it!

    It was so simple why didn't I think of it :P


    Thanks so much Nick.
     
Loading...

Share This Page