Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spamhaus PBL

Discussion in 'E-mail Discussions' started by larryl, Feb 23, 2015.

  1. larryl

    larryl Active Member

    Joined:
    Feb 19, 2007
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    156
    We've moved a couple of hundred sites to a new server. Both servers are on version 11.48.0.

    The old server has the zen.spamhaus.org RBL enabled, as does the new one. However, email users on sites moved to the new server are getting outbound email blocked with the message "JunkMail Rejected". When you follow the spamhaus link, it's because the originating IP address is at a provider like Comcast or Verizon, and they require outbound mail to go through their servers. Here's the text from the link:

    So it looks like a policy block, not a spam block. This only happens on the new server, not on the old one, so that tells me there is a setting somewhere to turn it off. Any ideas? I don't want to turn off spamhaus entirely, just the PBL.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,681
    Likes Received:
    299
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Are you running EXIM on a port other than port 25?
     
  3. Eric

    Eric Administrator
    Staff Member

    Joined:
    Nov 25, 2007
    Messages:
    752
    Likes Received:
    11
    Trophy Points:
    143
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Howdy,

    Use sbl-xbl.spamhaus.org instead this will load the Spam list and the eXploited list without the pbl list.

    Thanks!
     
  4. larryl

    larryl Active Member

    Joined:
    Feb 19, 2007
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    156
    Infopro - exim is running on all the standard ports - 25, 26, 465, 587.

    Eric - thanks, I'll try that.
     
  5. larryl

    larryl Active Member

    Joined:
    Feb 19, 2007
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    156
    This worked. I copied the text from the default Spamhaus RBL and modified it in the custom RBL block with the name you suggested. Thanks, Eric!
     
Loading...

Share This Page