The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

spamhaus_spamcop System RBL missing from WHM Exim Configuration

Discussion in 'E-mail Discussions' started by sneader, Sep 10, 2012.

  1. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    OK, help me out here... in the old days in WHM's Exim Configuration, under RBLs, there were checkboxes for:

    __ Spamcop
    __ Spamhaus
    __ Spamhaus and Spamcop

    So, with one checkbox, you could be using both Spamhaus and Spamcop RBLs. This last checkbox option seems to be missing.

    However, if I click on "Manage Custom RBLs" I still see:

    System spamcop bl.spamcop.net
    System spamhaus zen.spamhaus.org
    System spamhaus_spamcop zen.spamhaus.org, bl.spamcop.net

    So, that combo of Spamhaus and Spamcop still exists.

    I'm looking at one server now where the exim_mainlog CLEARLY shows I am blocking mail due to both Spamhaus and Spamcop RBLs... yet in WHM Exim Configuration, both Spamhaus and Spamcop are turned OFF (but I'm sure it's working because the "combo" is turned ON, with some hidden button somewhere??)

    Help?

    P.S. I am running the latest Stable: 11.32.4 (build 14)

    - Scott
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,453
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi Scott, I can't help much with this, but I can give you a few details.
    Changes in that UI are saved to this file:
    /etc/exim.conf.localopts

    There is an internal case about this (#59727) that I believe is related, that removed the acl_spamhaus_spamcop_rbl from the exim.conf.localopts file. That case is now closed.

    I suggest a ticket on this issue you're seeing. Please link to this thread in your ticket, and post back what you find out, please. :)
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,453
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    BTW:
    I do here as well on multiple servers.
     
  4. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Thanks Infopro. Indeed, in exim.localops, on all of my existing servers, I see:

    acl_spamcop_rbl=0
    acl_spamhaus_rbl=0
    acl_spamhaus_spamcop_rbl=1

    I guess for any new servers, it's not a big deal... I can just enable both Spamcop and Spamhaus separately, within WHM, and forget about the old "combo".

    For the old servers that have "acl_spamhaus_spamcop_rbl=1" (i.e. the "combo" enabled but hidden), it's more tricky. Essentially both RBLs are already enabled and working, BUT since the WHM Exim Configuration Editor hides that fact, it is confusing, especially since the Editor also will allow me to enable them separately (wonder what that would do??)

    Will open ticket per suggestion and let you know! Thanks again!

    - Scott
     
  5. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    OK, ticket #3142151 opened and received the following response:

     
Loading...

Share This Page