The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Special characters in upcp log causing email truncation

Discussion in 'General Discussion' started by David July, May 26, 2016.

  1. David July

    David July Member

    Joined:
    Jun 13, 2013
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I have an issue where my daily upcp --cron log email is truncated. The update process completes without issue and the log itself is intact on the server. Looking at that log, it appears that special characters are causing the email to be truncated.

    The problem occurs during the MySQL version check. Here is how this section of the log appears in my email.

    Code:
    [2016-05-26 01:02:15 -0400]  Checking MySQL Version
    [2016-05-26 01:02:15 -0400]  MySQL version b
    

    The email abruptly ends at that point. For comparison, here is how that same section appears in the log itself.

    Code:
    [2016-05-26 01:02:15 -0400]  Checking MySQL Version
    [2016-05-26 01:02:15 -0400]  MySQL version “5.6” is greater than or equal to the recommended minimum version, “5.5”.
    

    The log then continues for another hundred or so lines. As you can see, there are special characters surrounding the MySQL version numbers instead of quotation marks. This output is consistent with improperly encoded UTF-8 characters.

    Is there anything that I can do to fix this (i.e., replace the special characters with quotation marks) or does this need to be corrected by cPanel?

    Please let me know if you have any questions. Thank you.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    34,305
    Likes Received:
    999
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    I can't reproduce this behavior on email clients such as Gmail. Are you able to reproduce this issue across multiple email clients, or is it isolated to a specific one?

    Thank you.
     
  3. David July

    David July Member

    Joined:
    Jun 13, 2013
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello Michael and thank you for your response.

    The issue of the email being truncated appears to be limited to Outlook 2013. Other email clients appear to handle the special characters a little better.

    For example, K-9 Mail on Android displays three "question mark in diamond" symbols for each special character in the message (see attached). Alternately, the plain text email viewed in the inbox shows the same characters I pasted above, which appear in the log file itself.
     

    Attached Files:

  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    34,305
    Likes Received:
    999
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  5. David July

    David July Member

    Joined:
    Jun 13, 2013
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thank you, but those settings refer to outgoing messages.

    The special characters only started appearing in the log recently. Is there a process by which I can request an enhancement so the log file goes back to using standard question mark ("), apostrophe (') or grave accent (`) characters as it has previously?

    Thanks!
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    34,305
    Likes Received:
    999
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You can open a feature request for the addition of a template for the upcp cron email notification via:

    Submit A Feature Request

    However, I'd also like you to review the following third-party URL and let us know if this makes a difference in Outlook 2013:

    Why Outlook email messages show unreadable characters

    Thank you.
     
  7. David July

    David July Member

    Joined:
    Jun 13, 2013
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I reviewed the third-party page as requested. Here are the results.

    Outlook: the configuration already had the "'Straight quotes' with 'smart quotes'" option disabled.

    Word: the Latin string value under the \Fonts key had a value, however I updated the fonts to match those set in Outlook and confirmed that the registry was updated accordingly.

    Message: the encoding option for the ucpc log file message is set to "Western European (Windows)". Sure enough, when I switched this to "Unicode (UTF-8)" the entire message displayed.​

    Although the cPanel log files were the thing to change, it seems to me that Outlook is at the heart of this issue. Since manually switching the message's encoding to UTF-8 is possible for Outlook users, I consider this to be a suitable workaround.

    Thank you for your assistance with this.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    34,305
    Likes Received:
    999
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  9. jasammilan

    jasammilan Registered

    Joined:
    May 13, 2012
    Messages:
    2
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    I had the same problem with email truncation on line "MySQL version b" and character recognition in some other files.
    Cause of the email truncation is on first not recognized character (“ - left double quotation mark) in upcp log.

    I have fix this by setting locale from C to en_US.UTF-8 or you can set some other UTF-8 character set.
    Edit file /etc/sysconfig/i18n and change line with LANG variable to look like this:
    Code:
    LANG="en_US.UTF-8"
    Now reload locale with command:
    Code:
    source /etc/sysconfig/i18n
    or if you use sudo:
    Code:
    sudo source /etc/sysconfig/i18n
    With command "locale" you can verify that the system LANG is set to "en_US.UTF-8":
    Code:
    root@cp [~]# locale
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=
    root@cp [~]#
     
    cPanelMichael likes this.
Loading...

Share This Page