The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

speed scsi disk

Discussion in 'General Discussion' started by dethman, Feb 2, 2005.

  1. dethman

    dethman Well-Known Member
    PartnerNOC

    Joined:
    Jan 4, 2003
    Messages:
    120
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Buenos Aires, Argentina
    cPanel Access Level:
    DataCenter Provider
    hello, i have a problem with speed on scsi adapter or disk...

    i have whitebox linux with controller adaptec 29320A U320 and Seagate 73gb U320

    #lsmod

    aic79xx 181308 7
    diskdumplib 3616 0 [aic79xx]
    sd_mod 13712 14
    scsi_mod 104744 4 [sg ide-scsi aic79xx sd_mod]

    # hdparm -T -t /dev/sda

    /dev/sda:
    Timing buffer-cache reads: 1196 MB in 2.00 seconds = 598.00 MB/sec
    Timing buffered disk reads: 18 MB in 3.37 seconds = 8.31 MB/sec => its very low how to fix this?

    # hdparm /dev/sda

    /dev/sda:
    readonly = 0 (off)
    geometry = 8924/255/63, sectors = 143374744, start = 0

    # smartctl -a /dev/sda
    smartctl version 5.1-11 Copyright (C) 2002-3 Bruce Allen
    Home page is http://smartmontools.sourceforge.net/

    Device: SEAGATE ST373307LW Version: 0006
    Serial number: XXXXXXXXXXXXX
    Device type: disk
    Local Time is: Thu Feb 3 01:02:38 2005 ART
    Device supports SMART and is Enabled
    Temperature Warning Enabled
    SMART Sense: Ok!
    Current Drive Temperature: 42 C
    Drive Trip Temperature: 68 C

    Error counter log:
    Errors Corrected Total Total Correction Gigabytes Total
    delay: [rereads/ errors algorithm processed uncorrected
    minor | major rewrites] corrected invocations [10^9 bytes] errors
    read: 1388497 0 0 1388497 1388497 12661.590 0
    write: 0 0 0 0 0 4222.373 0
    verify: 5906 0 0 5906 5906 146.816 0

    Non-medium error count: 7526

    SMART Self-test log
    Num Test Status segment LifeTime LBA_first_err [SK ASC ASQ]
    Description number (hours)
    # 1 Background short Completed - 1 - [- - -]
    # 2 Background short Completed - 1 - [- - -]

    Long (extended) Self Test duration: 1488 seconds [24.8 minutes]
     
  2. jester.ro

    jester.ro Well-Known Member
    PartnerNOC

    Joined:
    Feb 6, 2004
    Messages:
    304
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bucharest, Romania
    cPanel Access Level:
    DataCenter Provider
    can you do a

    cat /proc/interrupts

    and post the results here?

    what processor(s) you have on that machine?
    cose the cached speed is also slow. I get twice as much on a p4 prescott 2.4 ghz, with IDE harddrive.
     
  3. dethman

    dethman Well-Known Member
    PartnerNOC

    Joined:
    Jan 4, 2003
    Messages:
    120
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Buenos Aires, Argentina
    cPanel Access Level:
    DataCenter Provider
    # cat /proc/interrupts
    CPU0
    0: 1782671 XT-PIC timer
    1: 2266 XT-PIC keyboard
    2: 0 XT-PIC cascade
    3: 0 XT-PIC usb-uhci
    5: 4935625 XT-PIC usb-uhci, eth0, eth1
    8: 1 XT-PIC rtc
    11: 1852088 XT-PIC aic79xx, usb-uhci, ehci-hcd
    NMI: 0
    ERR: 0

    I have a AMD Sempron 2600+ (1826Mhz) with 1gb ddr

    # cat /proc/cpuinfo
    processor : 0
    vendor_id : AuthenticAMD
    cpu family : 6
    model : 8
    model name : AMD Sempron(tm) 2600+
    stepping : 1
    cpu MHz : 1826.003
    cache size : 256 KB
    fdiv_bug : no
    hlt_bug : no
    f00f_bug : no
    coma_bug : no
    fpu : yes
    fpu_exception : yes
    cpuid level : 1
    wp : yes
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow
    bogomips : 3643.80

    # cat /proc/meminfo
    total: used: free: shared: buffers: cached:
    Mem: 985993216 910147584 75845632 0 70303744 495464448
    Swap: 2097405952 174350336 1923055616
    MemTotal: 962884 kB
    MemFree: 74068 kB
    MemShared: 0 kB
    Buffers: 68656 kB
    Cached: 396844 kB
    SwapCached: 87008 kB
    Active: 659048 kB
    ActiveAnon: 345148 kB
    ActiveCache: 313900 kB
    Inact_dirty: 140396 kB
    Inact_laundry: 28720 kB
    Inact_clean: 13804 kB
    Inact_target: 168392 kB
    HighTotal: 65472 kB
    HighFree: 1984 kB
    LowTotal: 897412 kB
    LowFree: 72084 kB
    SwapTotal: 2048248 kB
    SwapFree: 1877984 kB
    HugePages_Total: 0
    HugePages_Free: 0
    Hugepagesize: 4096 kB
     
  4. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    534
    Likes Received:
    0
    Trophy Points:
    16
    hmm, that is really bad performance... have you checked that your hdparm settings are correct? Have you played around with some higher performance settings?
     
  5. dethman

    dethman Well-Known Member
    PartnerNOC

    Joined:
    Jan 4, 2003
    Messages:
    120
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Buenos Aires, Argentina
    cPanel Access Level:
    DataCenter Provider
    have you checked that your hdparm settings are correct?
    How do this?


    Have you played around with some higher performance settings?
    Single httpd.conf, my.cnf and sysctl.conf but already restore to the original
     
  6. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    534
    Likes Received:
    0
    Trophy Points:
    16
    Code:
    man hdparm
    And search at google.com for some further info on what settings do, etc.

    When talking about higher performance settings, I was talking about hdparm settings.

    Though really, by default you should have better performance than that... so it's likely another problem... maybe drivers?
     
Loading...

Share This Page