The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SPF, Domain Keys and Other SMTP Server

Discussion in 'E-mail Discussions' started by noworyz, Feb 20, 2008.

  1. noworyz

    noworyz Registered

    Joined:
    Nov 25, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I have enabled SPF, Domain Keys for my domain on my server and have a question.

    I use Apple Mail with pop account and my ISP has blocked port 25 it seems as I can't get it to authenticate. Is it s a problem to use my ISP's outgoing server? I am just wondering if having the SPF and DK enabled would mess with the outgoing emails that are using a different outgoing mail server.

    I am kinda new to the email hosting thing so I could be completely off base here. Thanks for your help!
     
  2. Arhineus

    Arhineus Well-Known Member

    Joined:
    Nov 1, 2005
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Have you tried an alternate port?
     
  3. blkjck

    blkjck Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Enable port 26 on exim from the service manager, change your client to use port 26. You can also use smtp pop3 ssl ports also. This will bypass your ISP block on port 25. This block is quite common and has nothing to do with enabling domainkeys or SPF. If you decide to use your ISP for sending emails that use your domain as the return you will need to update SPF record to say your ISP's IP or mx name is permitted to send email on behalf of your domain. Once your client connects to the server on port 26 or SSL your ISP is no longer part of the process of mail being delivered.
     
  4. Kent Brockman

    Kent Brockman Well-Known Member

    Joined:
    Jan 20, 2008
    Messages:
    1,130
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Buenos Aires, Argentina
    cPanel Access Level:
    Root Administrator
    Twitter:
    I'm afraid of implementing that setting. Does this affect how the contact forms send emails? does this affect or must be reconfigured at any mailing system? (like them using phpmailer: Wordpress, mailing lists, etc)

    And remember to give advice to all the clients how to change their pop3 settings in order to receive emails.
     
  5. blkjck

    blkjck Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    @Kent Brockman: No it will not change any other settings on the server. Port 25 will still work as it has (it's not disabled), port 26 will just be enabled to answer as 25 does. POP3 settings are not changed. The ISP is not blocking your server from sending email. The block is from the home/work PC connecting to the SMTP port on the server. This is to block the ISP's users from being used as open SPAM bots. As far as existing clients, nothing has changed. Only the users that know their ISP blocks port 25 would change anything. They only need to change port 25 to 26 in their SMTP setup. If their ISP is not blocking port 25, they don't need to change a thing.
    If you are a business account of your ISP, you can contact them about lifting the block on your account for SMTP. Some ISP will do this for their business clients at no cost.
    When enabling the alternate SMTP port (WHM defaults to 26) remember you must enable inbound TCP to this port on the server firewall also.
     
  6. Kent Brockman

    Kent Brockman Well-Known Member

    Joined:
    Jan 20, 2008
    Messages:
    1,130
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Buenos Aires, Argentina
    cPanel Access Level:
    Root Administrator
    Twitter:
    Cool. 26 is the default port. May I use any other number like 2525 and still all your explanation will work?
     
  7. blkjck

    blkjck Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Yes, just remember to open the port in the firewall and the port does not conflict with any other port in use. Once enabled exim should restart and you will see the exim process running with that port number
    example ~ /usr/sbin/exim -bd -oX 26
     
    #7 blkjck, Feb 25, 2008
    Last edited: Feb 25, 2008
  8. Kent Brockman

    Kent Brockman Well-Known Member

    Joined:
    Jan 20, 2008
    Messages:
    1,130
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Buenos Aires, Argentina
    cPanel Access Level:
    Root Administrator
    Twitter:
    Cool. thanks!
     
  9. noworyz

    noworyz Registered

    Joined:
    Nov 25, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I enabled port 26 in service manager like you said and changed my outgoing server on my mail client to port 26 but it still doesn't work. Is there something else I missed? Thanks
     
  10. noworyz

    noworyz Registered

    Joined:
    Nov 25, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    just re-read the post and am working on enabling inbound traffic to that port. I'll update soon with success
     
  11. noworyz

    noworyz Registered

    Joined:
    Nov 25, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    enabled port 26 in firewall and it works great, thanks!
     
  12. blkjck

    blkjck Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    @noworyz Glad to hear it. Yeah that alt port option can come in handy. Using SSL ports on the client works also to get around the SMTP port block but IMO the port 26 is easier.
     
Loading...

Share This Page