The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SPF Not Authenticating/Blocking as Expected

Discussion in 'E-mail Discussions' started by Peter-L, Dec 2, 2012.

  1. Peter-L

    Peter-L Registered

    Joined:
    Dec 2, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hello,

    After reading through SPF: Project Overview and a few other posts on here I was hoping someone could help me work out why SPF isnt working.

    On my domain I have a txt record of - "v=spf1 a mx a:host1.domain a:host2.domain a:host3.domain a:mobile.domain a:laptop.domain -all"

    In cPanel SPF is Enabled and it has the following SPF value - "v=spf1 +a +mx +ip4:<Server Public IP> +a:host1.domain +a:host2.domain +a:host3.domain +a:mobile.domain +a:laptop.domain -all"

    As these .domain hosts are dynamic IPs I am running no-ip for my own domain.com.

    From my (limited) understanding of SPF after enabling this on cPanel I should only be allowed to send from -

    host1.domain
    host2.domain
    host3.domain
    mobile.domain
    laptop.domain

    However if I turn off no-ip domain updating and switch to a different IP address (turn off wifi on my mobile so it uses my 3G connection) I am still able to send mail from my domain.com to another address (hotmail).

    Anyone got any ideas/advice?

    Thanks,
    Peter
     
Loading...

Share This Page