The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SPF not working after update

Discussion in 'E-mail Discussions' started by mennis309, Jan 20, 2009.

  1. mennis309

    mennis309 Registered

    Joined:
    Jan 20, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    We have SPF blocking enabled for our mail servers through the WHM exim configuration option "Blacklist: SPF checking". After the CPanel automatic update last night, the SPF blocking is no longer working even though this option is still reporting as enabled. I have installed the exim.conf file from before the update last night and this re-enables the SPF blocking but I now get a warning about using the old configuration.

    Any idea why is this configuration option not working correctly and what I can do to sort this out?

    - Mark.
     
    #1 mennis309, Jan 20, 2009
    Last edited: Jan 20, 2009
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
  3. mennis309

    mennis309 Registered

    Joined:
    Jan 20, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel 11.24.4-R33385 - WHM 11.24.2 - X 3.9
    CENTOS 4.7 i686 on standard
     
  4. mennis309

    mennis309 Registered

    Joined:
    Jan 20, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I have reported this problem through my service provider, but so far they have just undone the changes I made to re-enable the SPF blocking.

    I was hoping someone here might have some idea if this problem is a problem with the general CPanel update or something specific to my environment.

    The exim configuration template changed version as follows:
    diff exim.conf /etc/exim.conf
    264c264
    < # cPanel Default ACL Template Version: 5.8
    ---
    > # cPanel Default ACL Template Version: 5.9
    433,435c433,434
    <
    < deny message = SPF: $sender_host_address is not allowed to send mail from $sender_address_domain
    < spf = fail
    ---
    >
    >

    - Mark.
     
    #4 mennis309, Jan 21, 2009
    Last edited: Jan 21, 2009
Loading...

Share This Page