The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SPF on Google Split Delivery

Discussion in 'E-mail Discussions' started by Gary_leeds, Aug 15, 2016.

Tags:
  1. Gary_leeds

    Gary_leeds Registered

    Joined:
    Aug 15, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Leeds
    cPanel Access Level:
    Root Administrator
    Hello,

    I have an issue with mail being rejected on my cPanel server when using Google For Work split delivery.

    So for all address which don't have a Google account get rerouted by google to my 'legacy server' (my cPanel server). Most mail arrives fine and works beautifully and ALL mail arrived fine until around 8th August after which point certain emails would be rejected due to SPF issues. I presume my server installed a cPanel update or something around 8th which changed something, probably turned on SPF checking.

    I know how to turn off the checking of SPF in the exim config. But I'd rather have it turned on as I have had email spoofing in the past and receive enough spam as it is, there are lots of other accounts on the server who would also benefit from it's protection.

    My question is, is there any way to turn off SPF filtering on one specific cPanel account or even a recipient address?

    Below is an example line from the reject log:

    2016-08-15 04:01:28 H=mail-yb0-f200.google.com [209.85.213.200]:35592 X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no F=<b0028a06fc5sales=mydomain.co.uk@bounce.twitter.com> rejected RCPT <sales@mydomain.co.uk>: SPF: 209.85.213.200 is not allowed to send mail from bounce.twitter.com

    Thanks in advance.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,476
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    In that accounts cPanel > Email section > Authentication, you can disable SPF for the domain if you wish.

    There's another thread, may not be related exactly, regarding twitter emails issue:
    Unable to receive emails from twitter for forwarders
     
  3. Gary_leeds

    Gary_leeds Registered

    Joined:
    Aug 15, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Leeds
    cPanel Access Level:
    Root Administrator
    This is for outgoing, not incoming mail.
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,476
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I wonder if you added: bounce.twitter.com to your SPF record if that would help?
     

    Attached Files:

  5. Gary_leeds

    Gary_leeds Registered

    Joined:
    Aug 15, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Leeds
    cPanel Access Level:
    Root Administrator
    No, because it's not just twitter. It's quite a lot of senders. The twitter log was an example from the log.
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,476
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    This appears to be related:
    58 Release Notes - Documentation - cPanel Documentation
     
Loading...

Share This Page